Missing libraries and 3d models in 5.99

I don’t understand the changes in paths and how to fix them. I thought it was just upgrading a 5.0 project, but I tried to start a new project and libraries and 3d models are all gone:

Library file “${KICAD_SYMBOL_DIR}\4xxx_IEEE.lib” not found.
Error loading symbol library 74xGxx

I have no resistors or capacitors. There are only 1045 items in my symbol library. And I get this for trying to add footprints

Footprint library path ‘${KISYSMOD}/Battery.pretty’ does not exist (or is not a directory).
Footprint library path ‘${KISYSMOD}/Button_Switch_Keyboard.pretty’ does not exist (or is not a directory)…

I guess when I upgraded, it just copied some settings instead of updating them? Maybe KISYSMOD is now KICAD6_3DMODEL_DIR C:\Program Files\KiCad\5.99\share\kicad\3dmodels\ ? But there is already a path to that. I did check the option to insall libraries during the install. Thanks for the help.

Which installer for 5.99 have you downloaded? Lite comes without libraries.

the 2 gigabyte windows full installer. This is a comparison of paths, first 5.1


Then 5.99


I am thinking of uninstalling and then re-installing and unchecking to box to pull in settings from 5.1. And to make sure I did not inadvertently uncheck one of the checkboxes for the install

FWIW, I downloaded the 5.99 lite (without libraries) installed it. Then I downloaded the V6 libraries in zip files and put them


I understand it isn’t the “standard” installation but it works for me.

1 Like

It may be enough to delete the library tables from your personal configuration (see Where are the configuration files (settings, library tables)?) and restart KiCad, then choose to copy the default library tables when KiCad asks about them.

The 3D models are a bit different. The footprint file in the official library has a pointer to a 3D model. That pointer is a path which has the name of the environment variable. If you have a design which you made when that pointer in the footprint file was still KICAD_3D… instead of KICAD6_3D… the footprint in the layout design points to an unknown location. You have to add the named environment variable to the KiCad variable list, or update the footprint from the current updated footprint library.

The library system of KiCad has good sides but sometimes it has painted itself in the corner. At least it would need more automatization for these kind of use cases.

That was what I needed to do. Now I’ll put back the paths to my personal libraries. But for the life of me I can’t get anything to show up on the PCB. There is not button for “update pcb from schematic” and in the menu, that option is grayed out in both eeschema and the pcb editor


I just went through this process. The reason is that the library path of 5.99 is different from that of 5.1. After the upgrade, the format of the user file is only changed, but the path is not modified synchronously.

Open your own PCB file with notepad++ and replace the old path in the file with the new path. Of course, you should keep a backup before trying to avoid losing the contents of the original file due to failure. For example:



Did you open the project with the main “kicad” program and not separate pcbnew and eeschema processes?

I did open the main program and then opened the project, and then clicked on the sch file to open it in eeshcema. I can edit it, check my footprints and open the pcb and there is nothing there. There is no button to update from the schematic. Yet now I can create another new file from scratch and it works. So still trying to see the pattern. At least I seem to have gotten the hang of paths and how to reconnect things based on all the help here.

Can you share the project? If yes, zip the whole project and attach it here.

5.99 is the unstable development version, so it’s possible that there’s some bug.

Thanks. Here is the simplest test. I’m not sure if I am missing something in the new version or if my paths still have a problem my projects are in the kicad folder, where the old kicad is. I have a “sandbox” folder and this test folder under that. 5.99 is in kicad, but in the 5.99 folder. It is just 3 components. Somehow, the first 2 components got in the footprint. This time when I opened the pcb editor, it let me click on the page and dump the components. So I added another capacitor. Now I can’t figure out how to update the schematic.Here is a zip of the files:

generic test.zip (257.8 KB)

Ok, I figured it out from your clue about “separate processes”. I am still trying to understand why KiCad would even allow this, but it was how I was opening each module. I thought I was opening from within the project, but must not have been. If it wasn’t for me finally hitting F8, even though "update PCB from schematic was grayed out, I would still be struggling. Doing that popped up an error box that said pcbnew was running stand alone and I needed to open it from the project. Nothing else shows that error.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.