Meaning of 'X' sign on SMD footprint

What does the ‘X’ on the footprint mean. It appears as soon as a track is connected to it.

This is a replacement for very short ratsnest lines. (Not sure if this is added to version 5 or if that is only in pre version 6 nightlies)

Which means you either have something on another layer that wants to be connected at this place or the traces to not really connect at this point. (or there is a bug, which might be likely if you are in the nightly build version)

Thanks for the swift response! Details:
Using Version KiCAD 5.1.5_2, release. Possibly a bug in this Version?
Highlighting net + checking unrouted connections + DRC seem to indicate correct connection to the pads.
Footprint based on TI Datasheet
Highlight net: Sign-on-footprint_2

Use outline modes, it’s easier to see where items actually are.

1 Like

Zoom in outline mode (KiCAD is great)

Do you have something in Back layer hidden? Such X appears when a track ends in the SMD pad center but in the other layer.

1 Like

In backlayer is ground plane. I removed it and result is the same.
Btw: Pin 2 has no X…

It would be easy to test if you gave the .kicad_pcb file.

Forum message: “Sorry, new users cannot upload attachments”
Tried also to rename the file to .jpg. Forum refuses due to ‘corrupt file’
Can I send it to you as “private message”?

Look around a bit on the forum that should promote you to the next trust level. (I think reading for 10 minutes or something like that. Possibly a number of different topics.)

And, BTW, there’s still probably the problem with the forum software that it doesn’t let us download kicad files. Zip it first and attach or copypaste the zip file into the message.

You can now.

blah, blah, 20

Zip was also refused. I retry tomorrow.

Finally, test-PCB and Model are here: (12.7 KB)

The footprint is made in a wrong way. There should be no reason here to have 3 pads for each pad, copper, paste and mask. One copper pad with clearance values (usually 0 to be able to inherit them from the board setup) for mask and paste should be enough. If you want to keep those aperture pads - which may be OK, too - they must not have pad numbers. Numbering them creates this “can’t connect” problem.

EDIT: Choose these if you don’t keep the extra aperture pads.

1 Like

I have not looked at the datasheet but there are plenty of reasons why one would use one pad per layer. If for example the datasheet gives absolute sizes for every layer then it is much easier to use one pad per layer. And if the different layers have different clearances per side then one must use one pad per affected layer.

However, if one does use a pad for only mask or paste then this pad must not have a pad number.

I didn’t check the datasheet, either. But all 3 pads are of identical size/shape, so there’s no reason for 3 pads (or the footprint is wrong anyways). The OP should of course consult the datasheet, check everything and make the decisions. I gave the options.

Those crosses are clearly NOT present in a master build. The most recent nightly version probably won’t show them either. Nothing to do with footprint design.

The official 5.1.5 version shows the crosses hence it would appear to be some bug.

It has everything to do with footprint design because aperture pads shouldn’t have pad numbers and the pad numbers cause the cross to appear. It can be seen as a bug or undefined behavior, of course.


How come it shows up ok in master? No crosses!