Manual build recipy for KiCad on Fedora 22

Below a recipe that I used to successfully build KiCad on Fedora 22 Workstation

Installing tools & libraries:

  sudo dnf install bzr bzrtools \
           bzip2-libs bzip2-devel \
           gcc-c++ \
           cmake cmake-gui patch swig \
           cairo-devel glew-devel grep openssl-devel wxGTK3-devel python-devel wxPython-devel boost-devel \
           doxygen dblatex asciidoc po4a

Make a working dir:

 mkdir -p ~/KiCad/src
 cd ~/KiCad/src

Clone sources from GitHub:

 git clone kicad
 git clone       kicad-library
 git clone           kicad-doc

Setup build:

mkdir -p ~/KiCad/build/Release
 cd ~/KiCad/build/Release
 cmake -G "CodeBlocks - Unix Makefiles" \
       -DCMAKE_BUILD_TYPE=Release \
       -DCMAKE_INSTALL_PREFIX="~/KiCad/kicad" \
       -DwxWidgets_CONFIG_EXECUTABLE='/usr/bin/wx-config-3.0'  \
       -DwxWidgets_USE_DEBUG=ON \

Build and install it in ~/KiCad/kicad

 cd ~/KiCad/build/Release
 make rebuild_cache install -j4

Build / install documentation:

mkdir -p ~/KiCad/build/doc
 cd ~/KiCad/build/doc
       -DCMAKE_INSTALL_PREFIX="~/KiCad/kicad" \
make install

Build / install library:

 mkdir -p ~/KiCad/build/library
 cd ~/KiCad/build/library
 cmake \
       -DCMAKE_INSTALL_PREFIX="~/KiCad/kicad" \
 make install

Binaries are found in ~/Kicad/kicad/bin

Don’t you have problems especially in eeschema due to wxWidgets3 being compiled against GTK3 rather than GTK2?

That is an interesting question. Was not aware of the GTK3 vs. GTK2. I
thought it seemed to run Ok but I admit had not used it in anger.

it does have a few little ‘visual’ issues. Like in pcbnew the layer
colour buttons seems to have too much inside margins and the colour is
now just a small vertical sliver. And in eeschema I have a ghost trail
of the cursor.

I ‘assumed’ that some of these were to do with that I was running Fedora
as a VM rather than native but it quite well be this GTK3 vs. GTK2 thing

I had setup the Fedora VM a platform to more easily debug in KiCad as I
am still struggling to get ‘debug’ to work under Windows.

I haven’t been following Fedora issues for a long time, but see:

Thank you. This is just what the Dr ordered. I juct completed this build on my Fedora22 image and it worked like a champ. thanks again.

EDIT - On my fresh total install, needed to install git.
sudo dnf install git

If you don’t use the legacy canvas on a system using wx with gtk3, you are not too affected on the crappy wx3 and gtk3 integration. Exact cause and fix unknown.

If you choose to do use wx with gtk3 you might be drawing blindly in eeschema though. Citing what I wrote about the topic on

Legacy Canvas and Wxgtk
The legacy canvas has problems with wxwidgets 3.0 built with gtk3, this combination is usually called wxgtk on various package distributions. Don’t be confused when you see wxgtk 3.0.0 in your package manager, this is usually reffering to the wxwidgets version, and not weather or not it is built against gtk3.
It has been seen that fedora 20, 21 and 22, builds against gtk3 and you will experience the symptoms described below.
The symptoms, is that eeschema zooming will be slow, and the graphics is not quite exact, try looking at the grid dots. And in pcbnew, the canvas does not really draw near properly at all.

nickoe, thanks for that info. On one of my systems ( xfce fedora 22 in VitualBox ) the build as described by MarcoHess worked perfectly, and no issues as you describe.
Now on my main system, a fresh xfce fedora 22 bare install, using the same recipe above, I see the symptoms as you describe. Zooming very slow, + + + symbols all over the path the cursor takes. Very unusable. I will read your full post to see if there is a solution., Until then, i installed the version in copr and it seems ok.

Followed information from nickoe links did this: 01-fixkicad.conf
re-built and it works perfectly.
( I am running an old AMD dual core w/ radeon video. )
(( my host for the vbox that worked is a windows host , on intel. so it did not have this issue)

Very Kool. thanks Marco and Nickoe