Lines wont connect in Schematic Layout Editor

I do not claim this to be a bug yet. It might just be something that is the result if a glitch or even update to Linux.

The issue: I have previously constructed files. I can remove anything, and edit anything. However, to draw a line, now requires that I zoom in and get the cursor just right, or the wire wont connect. I am used to the occasional mismatch of a mouse click and a wire end dangles. That can be fixed. This, it acts like there is nothing there to connect too.
The highlight tool is also effected as it will not connect to the new wire added. It is almost as if the wire is being added by a separate user other than the author.

This effects all old files and new files alike.

I uninstalled the editor and KiCad suite. I edited the software manager. Dumped legacy file update access. Reinstalled specific to Ubuntu: Focal. The issue persists. Maybe this is a setting messed up? Why do I have to zoom in to get the cursor in exactly the right place now?

For me this is a show stopper as it forces me to zoom into each and every connection and back out to make changes. Over and over. It will take hours longer to do anything.

The only change that happened on this PC I know if was that Gnome did some updates that required a restart. I would Like to think I should not need to dumb the OS and start fresh just to draw lines…

Screenshot from 2021-02-03 16-02-53|398x500


KiCad version? -----

If I was to guess I’d guess that the symbol pins are not aligned to the schematic grid.

Added the version.


Is your grid set to the default 50mil? You may have changed it to something finer to place text and forgot to set it back to 50… (See menu View/Grid Settings...)

I have been operating on 1mm since day one and generated all documents on this pitch. I only just started having trouble with existing and new documents yesterday.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.