Library links updating automatically

Hello all,

I am trying to figure out a strange issue. When I create a new project I copy over a group of library files that contain subcircuits for my schematic, but when I select the file and subcircuit for a particular circuit element it then changes the library file to a file in another project. Any ideas what might be causing this?

Using KiCAD 5.1.9


I’m guessing, but maybe you are mixing global and project specific libraries.

KiCad does not search for libraries, and copying some files to a project directory does make KiCad add those (library) files to a project.
If you have added another copy of those files to the global library tables however, then KiCad does see and use that other copy.

Hmmm, how do you define a library as a project vs global library? I manually select the file I want when choosing the subcircuit, and then when I close out of the selection menu KiCAD changes it to a different file (always the same one) so maybe it was added to the global library. Suggestions for checking/removing it?

Edit: It’s not in the symbol or footprint libraries (it shouldn’t be anyways).

1 Like

Sounds like there’s a mixup in this discussion between schematic symbol libraries and SPICE libraries.

I would zip up each project folder (the new one and the old one where the new one still incorrectly points to) and upload them so we can take a look at what’s going on. Hopefully, it can be duplicated on someone else’s machine, otherwise you might have to make a screengrab video detailing all your steps and the final problem. For the record, I do the same thing you say you’re doing and never had that issue…assuming I’m understanding you correctly, that is.

Sorry for the delay, didn’t see there was a response here. I can’t share my projects sadly. I will say the issue appears to be with what KiCAD thinks is the “Working Directory”. I kind of fixed the issue by moving the old project to a different location. Once I did that and tried to select the correct SPICE library it told me that it couldn’t find the “working directory”. I closed out of the error and then was able to proceed as normal.

I have several dozen projects and haven’t encountered this before, so not sure what the difference was, but I did try to create multiple new projects and they all referenced the same old project before I moved it. I have several other “old” projects that worked just fine the whole time… Not sure how to trace down the error with that information hah.

1 Like

Schematic symbol and footprint libraries can be either global or project specific, but this does not apply to spice (as far as I know, I don’t have much experience there) so Ste’s remark is to the point.

Could it be related to a space or other unusual character in a path name?
The KiCad people do put effort in it to make this work, but some path may have slipped through.

For posting an example, you don’t have to disclose your whole project. A minimum example with maybe just a single IC and a few resistors is even preferable. The simulation does not even have to work. In this case though, your problem may be difficult to replicate or verify.

1 Like

Yeah, I really appreciate all the people volunteering for this software.

The old and new projects share the same path, up to the project folder name, so I don’t think that’s an issue. I originally copied the schematic from the old project to start the new project, which could be part of the root cause. I’ve done it in the past though and didn’t have issues. I tried to recreate it today, but was unable to do so.

Thanks for the tip on the example!