KidCad 7 PCB editor won't snap to objects on non-active layer

I recently switched to KiCad 7 and ran into a problem. I don’t know if it’s a bug or just some setting that’s changed.

  • Open KiCad.

  • Open the PCB Editor.

  • Select EdgeCuts layer to make it active.

  • Draw a circle.

  • Select UserDrawings layer to make it active.

  • Draw a second circle some distance away from the first one.

  • Select the first circle.

  • With the cursor on the center point of the first circle, press M.

  • Move the first circle close to the second circle.

In KiCad 6, the circle you’re moving snaps to the center point of the other circle.

In KiCad 7, the circle does not snap to the center point.

It’s a problem for me, because I have reference geometry on the UserDrawings layer so I can align mounting holes etc. to the housing. Thanks in advance for any help.

1 Like

There is now a new tool called “Positioning Tool”

Select and highlight circle to move
Right click, select “Positioning Tool” then “Position relative to” or hotkey “Shift + p”.
From newly opened window click “Select Item”
Select and highlight second circle (where circle to move will finish)
Window re-opens then select OK

Active and non-active layers are inconsequential with this function.

There is a bit of experimenting needed with this new function. :slightly_smiling_face:

I’m a little puzzled, on my system the graphics have never snapped to other layers (not in Kicad v6 and now not in v7, just tested with v6.0.9).

My workaround would be to work completely on the User-layer (and there get the snapping feature) and after finishing the geometry change all desired graphic shapes to edge.cuts (this is now easily done with the properties panel).

Just tried above steps as described in the original post on my 6.0.10 and it does snap.

If you are far from the other circle there is only a cursor with cross as below:

As soon as you are near the centre of the 2nd circle the cursor changes to cross + a small circle (as on the picture below) and snapping at the same time.

Ah, that’s brilliant. Thank you for pointing this out.

1 Like

KiCad only snaps to objects on the same layer, yes.

There’s a wishlist for fixing this: Enable multi-layer hotspot snapping (#6266) · Issues · KiCad / KiCad Source Code / kicad · GitLab

Tried it on my testing VM Ubuntu and KiCAD 7. Works well!

and here is me thinking it was a snapping replacement, but it turns out to be for positioning in a snapping way :slightly_smiling_face:

Which version of the package are you using? Are you using software form the PPA or Flatpack/Snap?

PPA, v7 package dated 0213. But read my posts - it works are described by @jmk with the Positioning Tool.
The screenshots are from my other post in this thread are using v6 and I presume the OP expects to work it the same in v7.

[Off Topic] @greg_m did not want to hijack this thread. I was just asking about the version because I installed the PPA of v7 on my Ubuntu 22.10 but it is not working. There is something missing, EEschema and PCBNew are not launching. Someone said it is still to be built but there are some people that are already using it so I still don’t know if my system has an issue or if I just have to wait a little longer.

Still active issue.

Multilayer snapping used to work in KiCad 6, but doesn’t work in 7
Another thing that seems to be removed, is snapping to line intersections:
I often used construction lines like this in User.comments layer and then would snap objects to their intersections.

Position relative to refference item Shift-P would be good, however there is no way to select the intersection as a point to snap to. Does anyone know workarround to this?

Removed? Has it ever worked?

If you want to vote for a feature request, login to gitlab and give thumb up for the issue (there’s a link in the linked forum thread).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.