KiCad V5 on a Raspberry Pi 3 B+?


#1

KiCad is available as a download on the Raspbian distro of linux, but only about version 4.0.5 or so (I can’t cut and paste).

It is amazing how well KiCad works on this platform. However, it is missing all the great features of V5.

Attempting to design high quality Printed Circuit Boards with a ~$40 computer and Open Source software is a mind-blowing concept!

So, I don’t have a specific question as I don’t know yet the right question to ask. In general what would be the steps to run KiCad V5 on my pie?


Install Kicad on Raspberry Pï Debian
#2

Do I need a different version of Ubuntu? I was using a MATE version, and was informed that this might run KiCad V5 on that distro.

I can’t be the only one curious about running KiCad V5 on a Raspberry PI.


#3

gotta ask… whY???


#4

Quad-core A53 (ARMv8) 64-bit @ 1.4GHz
1GB LPDDR2 SDRAM
82mm x 56mm x 19.5mm, 50g

KiCad V4.0.5 runs very well, not as fast as my i7, but quite useable. The Raspberry pi is also quite a bit more portable than my desktop tower is.

I’m quite the beginner at this, so I know that I don’t know the right questions to ask. If I could get pointed in a general direction that would be a great help to me.


Install Kicad on Raspberry Pï Debian
#5

It should work.

I use ArchLinux and I can see Kicad5 listed in the arm repo: https://archlinuxarm.org/packages

I don’t use Ubuntu, but if they have not updated the official repositories, you can submit a ticket there saying it is out of date. You also have the option of compiling Kicad from source code.


#6

OpenGL might still be a problem. See Install Kicad on Raspberry Pï Debian and a link there. But I’m not really familiar with the situation.


KiKad 5.0 on Raspberry?
#7

Almost 2 weeks into this issue and I have made some progress!

One major consideration is, “What does one want to do with their RasPi”? Once I had it out of the box I was curious about pushing the limits of the performance of the RasPi3B+. Over the last year I have spend quite a bit of time with (essentially) KiCad V5 and figured that for me it would be a good “real world productivity test” instead of running test programs that spit out numbers.

The RasPi3B+ seems to still be too new to have good Google searchable information; what I type here today might be obsolete in 2 weeks.

Ubuntu on the X386 instruction set (I think this is correct) is very well refined from my experiences with it; most “things” just work without having to reboot; this belief really slowed me down with the ARM instruction set.

(There is a video on YouTube about installing Ubuntu Mate onto a RasPi3B+ and it requires also having a RasPi3 to swap the SD card between the two.)

The current answer is “berryboot”. Berryboot has “NOOBS” GUI and also a compatible Ubuntu Mate OS available for installation.

Still not figured out, is exactly how to set up the under/over scan for the monitor that I am using; this can make the WiFi difficult to select to setup.

It took over an hour for me to finally give up on the WiFi to my Hotspot to work. Using Sneaker Net I was all over the place to confirm that all the settings were correct.

Once I re-booted the RasPi, the WiFi connected instantly… hour+ spent on this… not so happy am I.

At this point I updated the OS with the Terminal command. My friend tells me that this might have been a mistake; I did not know any better. There is the option to use a GUI updater thingy that does what the Google inspired Terminal commands do.

The system went to about 11, then decided to inform me that the file location was locked. Another Google and I got a Terminal command to change the lock setting on that folder/file location.

Somewhere in that timeframe I decided to reboot with new updates.

This changed my screen appearance; better but not perfect. At this time I still don’t know how to get the screen resolution to perfectly fit my Sony TV viewing monitor.

WiFi engaged to my Hotspot I navigate to KiCad.org and followed the Terminal text command to download KiCad V5.

I ended up with some version of KiCad V4… not to happy about that; and I do not yet know the fix.

The Raspberry Pi 3 B+ will do many computer tasks reasonably well; especially when considering the price.

There is not a lot of information on the interwebs about pushing this version of the Pi to it’s performance limits.

Anyone have any idea to upgrade to KiCad V5 in Ubuntu Mate?


#8

It’s not :slight_smile: but it’s not relevant. See https://en.wikipedia.org/wiki/X86.


#9

Maybe you can ask @jsreynaud if it’s possible to add the ARM architecture to the ppa builds. I don’t know if it’s easy with lauchpad - maybe it can be just added as a target? And I don’t know if it would be different for Pi than for general ARM architecture.

You can always try to compile yourself, using your Pi for that. It will be slow (one or two days maybe?).

For compiling read my long post in SOLVED: Compiling V5 RCs on Debian. Especially “apt build-dep” makes your life easier, but unfortunately you have to add things manually. Play with it for a while and ask when you get stuck.


#10

@eelik I’m gona add ARM arch on PPA…


#11

Following this thread as the computer i use most often, currently for all my kicad work, is a Pi.