KiCad simulation errors

I am trying to simulate circuits with different packages. I tried this on KiCAD version 6 then 8 on Linux. When I migrated to 8, I recreated the circuits from scratch. No matter what I did I got the same results.

The first circuit I made that gave me errors was with version 6, I got the symbol from the manufacturer website that linked to Ultra Librarian. I loaded the symbol into the library just fine. I went to the properties of the symbol on the schematics and I clicked on Simulation Model Editor. It needed a *.lib file for the simulation. The downloaded symbol didn’t come with a *.lib file. I went back to the site and got the KiCAD version 5 symbol which was a *.lib and used that as the *.lib file but it still gave me errors as well.

Then I upgraded to version 8. I recreated the circuit from scratch. It gave me similar errors as well and it is still needs a *.lib file for the Simulation Model Editor.

PICTURE 1 is below because I am a new user and I am only allowed 1 embedded media. Notice there is no ERC errors.

This is the latest version of KiCAD that I used:

I tried the same model with symbols, for another CAD on Windows 10 (I don’t know if I can mention the other CAD), that I got the same way from Ultra Librarian. It also expected a *.lib for that symbol for the simulation but again there was no *.lib file for that either. However, It loaded the symbol into the symbol library fine.

I went to SAMACSYS and downloaded the symbols of the same model for both CADs. The KiCAD folder had a kicad_sym file and a lib file. I created the circuit from scratch and it gave me similiar errors for the simulation. The other CAD was still missing a lib file for the simulation for that CAD tool.

PICTURE 2 is also below. Notice, there are no ERC errors.

I tried a regular voltage source and resistor and the simulation worked fine. I added a symbol from the default library and it also gave me simulation errors.

PICTURE 3 is below also. Notice again, the ERC gave me no errors, just an ignored test.

I also tried another model with different symbols from SAMACSYS and Ultra Librarian for KiCAD on Linux and the other CAD tool on Windows 10 but the problems are still the same or very similiar. 4 total for the other model. But what I do not understand is how did I get errors from using a symbol from the default library in KiCAD. That is what lead me here first.

How do I fix the simulation errors? I googled these problems but I couldn’t gather enough information to fix the problems so I am hoping I will find an answer here. Any help is appreciated. Sorry for the long post. Let me know if you need more information.




If you want to simulate something, you firstly will need some symbols to draw your circuit in Eeschema. For devices beyond R, L, C and some other basic dvices you then will need a spice model. These models are not provided by KiCad/ngspice, but have to obtained from other sources like Spice models and model parameters for ngspice circuit simulator.

Please have a look at and KiCad Eeschema as GUI for ngspice, tutorial for setting up the simulation.

Thank you for the resources. I think there is a miscommunication and I am sorry for any miscommunication on my part. Are you saying the AM2302 symbol that I found in KiCAD and shown in picture 3 is not a spice model and that I can’t simulate it?

A symbol is not a spice model. To simulate your circuit, you will need a spice model of the AM2302, attach it to the symbol, and check for the pin assigment. Only then you may run a simulation.

Spice models are typically made and distributed by the device manufacturer. If there is no spice model available, you cannot simulate the device with ngspice.

If your AM2302 is the Digital relative humidity & temperature sensor AM2302/DHT, then I fear there will be no spice model. This device contains sensors and a microcontroller and delivers digital data. A micro cannot be simulated by any spice simulator.

Unfortunately this is a completely wrong approach. To simulate, you don’t need a .lib file, but a file containing a valid spice model for your device. The file name does not matter. There is no guarantee that a file with ending .lib contains a spice model! The files coming with KiCad do not!

So I have to go to the manufacturers for each of the devices and ask for the spice models? The symbols are just for the circuit design to turn into pcb design? What good is a symbol without a spice model?

Not everything needs to be simulated.

A symbol is the graphical representation of a device. It may become part of a circuit diagram, where its connections to other devices are defined, to create the circuit. In conjunction with its footprint it is used to generate a PCB. In conjunction with a spice model it allows its device to be simulated (inside of its circuit).

No, you don’t need to go to the manufacturer for each of the devices. As I already have said, you may have a look at Spice models and model parameters for ngspice circuit simulator.

This topic was automatically closed after 90 days. New replies are no longer allowed.