KiCad not starting on MacBook Pro

I am a first time user and trying to install KiCad on my MacBook Pro. I can drag the .dmg files and install them OK BUT when I click on the KiCad Icon or open the application in the applications folder all I get is the KiCad Icon on the bottom toolbar as if it is open but NOTHING on the screen. Going to the menu options at the top of the screen I can open schematics and layouts but trying to open a complete folder just does not work. I cannot get the main KiCad start screen to appear no matter what I do.

It all works on my virtual windows machine but NOT on the MacBook.

Any suggestions - most welcome

Kicad version?
OSX version?

Hi Rene and thanks for the quick response.

I have tried the stable version 4.0.7 and also the nightly download version both have the same problem.

OSX is High Sierra 10.13.4

I have not had this problem, but there have been a couple of threads on the forum recently (this one and this one) that sound like the same thing.

Just a hunch, but is the main window perhaps positioned off screen? Try entering and exiting full screen mode and see if that helps.

More at Main kicad 5.0 window missing (OS X)

  • ff

Thanks for the answers but they do not work I’m afraid.

I get the menu bar at the top of the screen and the schematic and PCB design options work fine BUT I cannot open a complete project as I do not have a project window.

I do not get the green dot full screen option or a ‘view’ option on the menu bar so can only toggle to full screen mode with ctrl+cmd+f which does nothing when I am in KiCad. If I right click the KiCad icon on the dock, and click on the ‘show all windows’ option, all my desktop icons disappear and I get a blue outline of 3/4 of a window at the bottom of the screen. I cannot move this window or resize it and clicking anywhere just reverts to my normal desktop window

Any more ideas welcome

If you create and save a new schematic (from the menu that you can access) can you then open this as a project? I think you might need a .pro file to exist in your folder for Kicad to open it in the project manager view. I have run a variety of 4.0.x and nightly versions on a MBP with no problems.

I have downloaded a complete project file for another board from

From the menu I can open the project although no window opens so I don’t know if it has opened or not. However, if I open eeschema the schematic appears so the project must have loaded …

I can see and change the schematic in eeschema, no problems and I can see and change the layout in pcbnew but I cannot open the total project and get the project window to show.

What happens if you double click on the file?

Hi John

Sorry for the late response - I am in the US at the moment.

If I double click on the file in finder, it opens KiCad in the dock, and in the menu bar at the top of the screen but there is no project screen. It has opened the project because if I select eeschema or pcbnew the correct files open straight away. It is just the main project window that never comes up.

Have you tried removing the preferences in ~/Library/Preferences/kicad? If it was a brand new install I would be surprised if this caused a problem but might be worth a try.

I think the links that @ppelleti & @fearless suggest swapping in and out of full screen but you say you have tried that/can’t do that with the traffic light buttons?

In 5.0 nightly, at least, there is a ‘view’ menu entry which allows you to switch to full screen mode without using the traffic lights. Worth giving that a try too. Do you have an external monitor plugged in?


Thanks John

I moved the KiCad 4.0 application to the trash and then downloaded the latest version 5 and got the same result…HOWEVER…now I had the ‘view’ option for full screen mode, I selected this and hay-preto it came up into the project screen and was still there when I exited full screen and re-sized the window. Now it comes up every time I open KiCad…PROBLEM SOLVED.

Thanks again for your help


1 Like

The preferences save the frame size and position. Not sure what they are set to by default - I can’t see this issue reported on the bug tracker and it seems to have caused problems for others so should be reported at
Glad you got it working.

Submitted bug report under:

Indeed its a issue in default frame size and position. I recently faced this issue and found out problem and sent a patch to developer list, which has been merged into master.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.