Kicad nightly: OCC conflict with FreeCAD daily (nightly)

Hi,
recently on Ubuntu/Mint 20 FreeCAD daily (nightly) has switched to OCC 7.5.1 (previously it was on OCC 7.3)
This is creating an issue with KiCAD-nightly which relies on OCC 7.3
Would it be possible to build the KiCAD debian package on OCC 7.5 as to allow the coexistence of both sw?
here the FreeCAD PPA:

1 Like

Wasn’t @tijuca somehow involved with the packing of KiCAD on Ubuntu ? (sorry if I misremembered)

No, I’ve nothing to do with Ubuntu and their packaging. I’m (only) maintaining the Debian packages of KiCad.

2 Likes

Sorry I got confused, anyway thank you for your time and effort!

@jsreynaud packages the Ubuntu nightlies.

It looks like libocct-* are not packaged for 7.5.1 on Ubuntu Focal (only 7.3) so I’m confused how FreeCAD has changed?

FreeCAD builds their own PPA for libocct. We use their PPA for Xenial and Bionic where OCC was not packaged for Ubuntu.

If we also used it for Focal and Groovy, it would force uninstall the stable KiCad packaged with the distros (5.1.5 & 5.1.6) because OCC 7.5.1 and 7.3 are mutually exclusive. We could potentially require users to also use the PPA for stable KiCad but first Jean-Samuel is checking to see how hard it would be to add version+ (i.e. >=7.3) dependencies instead.

5 Likes

Hey Folks, there should be some new nightlies up with the OCC logic for both 7.3 or 7.5. Please try them out and let us know if it is still not working

3 Likes

Hi @Seth_h
I’ve just checked and still I cannot install k-nightly.
Here my commands:
sudo add-apt-repository ppa:kicad/kicad-dev-nightly
sudo apt update
sudo apt install kicad-nightly
here the errors:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kicad-nightly : Depends: libocct-data-exchange-7.3 but it is not going to be installed
Depends: libocct-foundation-7.3 but it is not going to be installed
Depends: libocct-modeling-algorithms-7.3 but it is not going to be installed
Depends: libocct-modeling-data-7.3 but it is not going to be installed
Depends: libocct-ocaf-7.3 but it is not going to be installed
Recommends: kicad-nightly-doc-en but it is not installable
E: Unable to correct problems, you have held broken packages.

Is there a way to specify to install k-nightly using OCC 7.5 libs?

I’m on:
‘Linux Mint 20.1, code-name “Ulyssa”. It includes Linux Kernel 5.4, based on Ubuntu 20.04’

I get the same error

Hmm… We may have skipped yesterday’s build. I see the amd64 deb is still trying to build. Says it should be done in another couple of hours. Once the build (https://launchpad.net/~kicad/+archive/ubuntu/kicad-dev-nightly/+build/21177970) finishes, can you please try again?

work like a charm

Thanks a lot! :smiley: :smiley: :smiley:

2 Likes

All thanks go to @jsreynaud for figuring this out! Glad it is fixed for you

I’m still busted with a variant of what’s described above and wondering if it’s related. Without freecad daily installed, I can’t install nightly. This is on a freshly installed Ubuntu 20.10 after adding the ppa per instructions.

$ sudo apt install kicad-nightly
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kicad-nightly : Depends: libocct-modeling-algorithms-7.3 but it is not installable or
libocct-modeling-algorithms-7.5 but it is not installable
Depends: libocct-modeling-data-7.3 but it is not installable or
libocct-modeling-data-7.5 but it is not installable
Depends: libocct-data-exchange-7.3 but it is not installable or
libocct-data-exchange-7.5 but it is not installable
Depends: libocct-visualization-7.3 but it is not installable or
libocct-visualization-7.5 but it is not installable
Depends: libocct-foundation-7.3 but it is not installable or
libocct-foundation-7.5 but it is not installable
Depends: libocct-ocaf-7.3 but it is not installable or
libocct-ocaf-7.5 but it is not installable
Recommends: kicad-nightly-libraries but it is not going to be installed
Recommends: kicad-nightly-doc-en but it is not installable
E: Unable to correct problems, you have held broken packages.

Is this related to the same issue for resolving the conflict with freecad daily (which I haven’t installed yet on this machine, but will be in the future)? This all seems to have gotten wedged a couple of days ago.

How do I fix this? Please teach me to fish if this is something I can address on my end.

Update:

Installing FreeCAD-daily changes this to the following:

$ sudo apt install kicad-nightly
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libocct-data-exchange-7.5 : Breaks: libocct-data-exchange-7.4 but 7.4.1+dfsg1-2 is to be installed
libocct-foundation-7.5 : Breaks: libocct-foundation-7.4 but 7.4.1+dfsg1-2 is to be installed
libocct-modeling-algorithms-7.5 : Breaks: libocct-modeling-algorithms-7.4 but 7.4.1+dfsg1-2 is to be installed
libocct-modeling-data-7.5 : Breaks: libocct-modeling-data-7.4 but 7.4.1+dfsg1-2 is to be installed
libocct-ocaf-7.5 : Breaks: libocct-ocaf-7.4 but 7.4.1+dfsg1-2 is to be installed
libocct-visualization-7.5 : Breaks: libocct-visualization-7.4 but 7.4.1+dfsg1-2 is to be installed
E: Unable to correct problems, you have held broken packages.

On https://launchpad.net/~kicad/+archive/ubuntu/kicad-dev-nightly/+packages there’s no package for opencascade for groovy and focal. Is that intentional?

Output from apt-cache:

$ apt-cache showpkg kicad-nightly
Package: kicad-nightly
Versions:
202103190931+472d0e03fc~119~ubuntu20.10.1 (/var/lib/apt/lists/ppa.launchpad.net_kicad_kicad-dev-nightly_ubuntu_dists_groovy_main_binary-amd64_Packages)
Description Language:
File: /var/lib/apt/lists/ppa.launchpad.net_kicad_kicad-dev-nightly_ubuntu_dists_groovy_main_binary-amd64_Packages
MD5: 72c04ae16902364d0d7d4fda98c87042
Description Language: en
File: /var/lib/apt/lists/ppa.launchpad.net_kicad_kicad-dev-nightly_ubuntu_dists_groovy_main_i18n_Translation-en
MD5: 72c04ae16902364d0d7d4fda98c87042

Reverse Depends:
kicad-nightly-dbg,kicad-nightly 202103190931+472d0e03fc~119~ubuntu20.10.1
kicad-nightly-templates,kicad-nightly
kicad-nightly-symbols,kicad-nightly
kicad-nightly-packages3d,kicad-nightly
kicad-nightly-libraries,kicad-nightly
kicad-nightly-footprints,kicad-nightly
kicad-nightly-demos,kicad-nightly
Dependencies:
202103190931+472d0e03fc~119~ubuntu20.10.1 - libc6 (2 2.29) libcairo2 (2 1.14.0) libcurl4 (2 7.16.2) libgcc-s1 (2 3.4) libgl1 (0 (null)) libglew2.1 (2 1.12.0) libglib2.0-0 (2 2.35.9) libglu1-mesa (16 (null)) libglu1 (0 (null)) libgtk-3-0 (2 3.9.10) libocct-data-exchange-7.4 (0 (null)) libocct-foundation-7.4 (0 (null)) libocct-modeling-algorithms-7.4 (0 (null)) libocct-modeling-data-7.4 (0 (null)) libocct-ocaf-7.4 (0 (null)) libpixman-1-0 (2 0.15.14) libpython3.8 (2 3.8.2) libstdc++6 (2 9) libwxbase3.0-0v5 (2 3.0.5.1+dfsg) libwxgtk3.0-gtk3-0v5 (2 3.0.5.1+dfsg) zlib1g (2 1:1.1.4) python3-wxgtk4.0 (0 (null)) libngspice-kicad (16 (null)) libngspice0 (0 (null)) xsltproc (0 (null)) kicad-nightly-demos (0 (null)) libocct-modeling-algorithms-7.3 (16 (null)) libocct-modeling-algorithms-7.5 (0 (null)) libocct-modeling-data-7.3 (16 (null)) libocct-modeling-data-7.5 (0 (null)) libocct-data-exchange-7.3 (16 (null)) libocct-data-exchange-7.5 (0 (null)) libocct-visualization-7.3 (16 (null)) libocct-visualization-7.5 (0 (null)) libocct-foundation-7.3 (16 (null)) libocct-foundation-7.5 (0 (null)) libocct-ocaf-7.3 (16 (null)) libocct-ocaf-7.5 (0 (null)) kicad-nightly-locale-bg (0 (null)) kicad-nightly-locale-ca (0 (null)) kicad-nightly-locale-cs (0 (null)) kicad-nightly-locale-de (0 (null)) kicad-nightly-locale-el (0 (null)) kicad-nightly-locale-es (0 (null)) kicad-nightly-locale-fi (0 (null)) kicad-nightly-locale-fr (0 (null)) kicad-nightly-locale-hu (0 (null)) kicad-nightly-locale-id (0 (null)) kicad-nightly-locale-it (0 (null)) kicad-nightly-locale-ja (0 (null)) kicad-nightly-locale-ko (0 (null)) kicad-nightly-locale-lt (0 (null)) kicad-nightly-locale-nl (0 (null)) kicad-nightly-locale-pl (0 (null)) kicad-nightly-locale-pt (0 (null)) kicad-nightly-locale-ru (0 (null)) kicad-nightly-locale-sk (0 (null)) kicad-nightly-locale-sl (0 (null)) kicad-nightly-locale-sv (0 (null)) kicad-nightly-locale-zh (0 (null)) kicad-nightly-libraries (0 (null)) kicad-nightly-doc-en (0 (null)) extra-xdg-menus (0 (null))
Provides:
202103190931+472d0e03fc~119~ubuntu20.10.1 -
Reverse Provides:

Thanks,
Christian

FWIW, this does not happen on Hirsute, installs just fine. Seems to be contained to Groovy.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.