Kicad-nightly: 'Failed to load kiface library'

Wanted to go for a session with kicad-nightly @Fedora37 but got:
Failed to load kiface library '/usr/lib64/kicad-nightly/bin/_eeschema.kiface'

Mainstream kicad works but of course, can’t open my nightly projects so i have to fix this!

The solution proposed here → ‘reinstallation’ doesn’t help.

Inside ‘/usr/lib64/kicad-nightly/bin’ there’s the affected file _eeschema.kiface:

-rwxr-xr-x. 1 root root 3237824 Nov 29 20:40 bitmap2component
-rwxr-xr-x. 1 root root 18406328 Nov 29 20:40 _cvpcb.kiface
-rwxr-xr-x. 1 root root 101528 Nov 29 20:40 dxf2idf
-rwxr-xr-x. 1 root root 1603912 Nov 29 20:40 eeschema
-rwxr-xr-x. 1 root root 26683472 Nov 29 20:40 _eeschema.kiface
-rwxr-xr-x. 1 root root 1599808 Nov 29 20:40 gerbview
-rwxr-xr-x. 1 root root 13628728 Nov 29 20:40 _gerbview.kiface
-rwxr-xr-x. 1 root root 337280 Nov 29 20:40 idf2vrml
-rwxr-xr-x. 1 root root 37056 Nov 29 20:40 idfcyl
-rwxr-xr-x. 1 root root 28832 Nov 29 20:40 idfrect
-rwxr-xr-x. 1 root root 4467296 Nov 29 20:40 kicad
-rwxr-xr-x. 1 root root 3283504 Nov 29 20:40 kicad-cli
-rwxr-xr-x. 1 root root 2143376 Nov 29 20:40 _kipython.kiface
-rwxr-xr-x. 1 root root 1595752 Nov 29 20:41 pcb_calculator
-rwxr-xr-x. 1 root root 3542920 Nov 29 20:40 _pcb_calculator.kiface
-rwxr-xr-x. 1 root root 1603928 Nov 29 20:41 pcbnew
-rwxr-xr-x. 1 root root 37277944 Nov 29 20:40 _pcbnew.kiface
-rwxr-xr-x. 1 root root 1599808 Nov 29 20:41 pl_editor
-rwxr-xr-x. 1 root root 13138688 Nov 29 20:40 _pl_editor.kiface

Please help! What’s next?

I have experimented with downgrading kicad-nightly… doesn’t help.
I’m pretty sure this i related to fedora 37!

I did an update / upgrade cycle on my Mint box and I could still open a project and schematic in KiCad-nightly. So I can’t reproduce it.

paul@cezanne:~$ sudo apt upgrade
Reading package lists… Done

Need to get 466 MB of archives.
After this operation, 185 kB disk space will be freed.
Do you want to continue? [Y/n]
Get:1 Triple - Mirrors una/upstream amd64 firefox amd64 107.0.1+linuxmint1+una [63,7 MB]
Get:2 Index of /kicad/kicad-dev-nightly/ubuntu focal/main amd64 kicad-nightly-footprints all 202212021916+1ee260211~14~ubuntu20.04.1 [23,1 MB]
Get:3 Index of /kicad/kicad-dev-nightly/ubuntu focal/main amd64 kicad-nightly-packages3d all 202212012119+248c290e~13~ubuntu20.04.1 [378 MB]
Get:4 Triple - Mirrors una/upstream amd64 firefox-locale-en amd64 107.0.1+linuxmint1+una [735 kB]

False Alarm. With a fresh install now works again.
Never major-upgrade your fedora distro (Why is this buggy option even offered).

Upgrading the distro works fine (I always update my Fedora versions from one to the next, and have some that have been upgraded all the way from Fedora 32/33 till now).

What happened is an underlying library that KiCad uses (wxWidgets) changed how it was built. That change necessitated a change in a build option for KiCad. The official package fix was coordinated by the Fedora packager of the wxWidgets library, and so KiCad was updated alongside that change to make everything work seamlessly. The nightly is built differently from the official package, and the change couldn’t be made to that until the actual official package and updated library had been released to users. The nightly build maintainer worked on integrating the required change yesterday, so the new build had the fix.


today, 01/25/23, after upgrade from 36 to 37 (fedora) ! (Nightly 7) !
Reinstall don’t work. Kicad 7 release don’t work too ! :frowning:
What can I do ?

Thanks !

Working again ! Thanks to the team, for the last update !

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.