KiCad crashes every time when opening pcb file


C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\Atmel\AVR Tools\AVR Toolchain\bin;C:\WinAVR-20090313\bin;C:\WinAVR-20090313\utils\bin;C:\csvn\bin;C:\csvn\Python25;C:\Program Files (x86)\AMD APP\bin\x86_64;C:\Program Files (x86)\AMD APP\bin\x86;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files (x86)\Microchip\xc8\v1.32\bin;C:\Program Files (x86)\Microchip\xc16\v1.21\bin;C:\Program Files (x86)\Microchip\xc32\v1.32\bin;C:\Program Files (x86)\QuickTime\QTSystem;C:\Program Files\Microsoft SQL Server\110\Tools\Binn;C:\Program Files (x86)\Microsoft SDKs\TypeScript\1.0;C:\Program Files\TortoiseSVN\bin;C:\Program Files (x86)\AMD\ATI.ACE\Core-Static

C:\Program Files\KiCad\share\kicad\template

C:\Program Files\KiCad\share\kicad\modules\packages3d

C:\Program Files\KiCad\share\kicad\modules

Released in 2006, maybe???

haha… Subversion uses it.

that’s the Path variable from the upper or lower window?
I’d bet from the lower window as it misses the python paths that you get when you install the interpreter and has got the AVR stuff in there that I got in the lower window’s Path variable as well.

Also worth a try, start the machine in Safe Mode and see what happens when you start pcbnew via commandline?

If you navigate with the Explorer and in the left pane (Tree View) you use [Shift]+[RightMouseButton] on the folder you want to get a command line window in you get there faster and easier :wink:

One more thing to try.
Reading about Windows 7.
Don’t try using Boost C++ 1.59 on Windows 7 64. Your PATH looks like you are a software developer, so I am wondering if you are doing this. It makes pcbnew crash immediately

Yes, you are correct. That’s the path from the lower window. The upper window didn’t actually have a PATH variable.
I have since updated Python to 2.7.11, the most current. The Path from the upper window only has c:\python27\ in it. Python is working fine though.
PCBNEW still crashes.

Hi there.
Yes I am a developer but not software, embedded hardware which means I do a lot of programming for non-PC processors and microcontrollers and a lot of PCB designing. This why I like KiCad.

So I did look into BOOST libraries and the version I have is 1.60… maybe. It seems hard to determine since I never actually installed them specifically. I have almost given up on the latest version of KiCad on my Win7 64b PC but I thought I would try to use winbuilder to build KiCad myself. I got it from GitHub. I did it last time in 2015 and it worked fine. This time it seems to have problems with cmake recognizing the version of Python. (I found that the version of BOOST in the winbuilder files is 1.6, which confuses me since that link indicates 1.57 or lower only works.)

problems… problems…

Anyways, I Just tried Kicad on my Win7 32 bit PC and there is no problem with it. This means that this stable version does not work on Win7 64 bit PCs. That’s OK for now. I’ll just use the Win10 tablet for a while until the developers fix this.

Thanks for all the help everybody. I think I should just leave this for those developing KiCad. My skillset doesn’t really include PC software development. Unless someone knows a sure way to replace the boost libraries on a win7 64b PC. haha…

I just waded through launchpad and could not find a bug highlighting the the 1.59 issue, so 1.60 may also be incompatible. I suggest you raise your own bug and label it something like pcbnew crahes on opening, possible problem with boost 1.60 on Win 7 64, so that the developers can become aware

Seems like it has been around for a while. But it also seems like it has been fixed, for winbuilder.
I found this post (

However, this is regarding building KiCad yourself. It didn’t work for me but it could be for another reason - a problem with the building process.

I just submitted a bug report. (

I am also getting same issue.

I downloaded Kicad 4.0.4. And Installed it on windows 7.

I am able to open project, schematic editor.

But when I try to open PCB New or PCB Footprint editor. It suddenly stops without any error message.

I believe this seems similar issue faced by djung1000

OS is Windows 7 64 bit.

Any solution for this Kicad 4.0.4?

I have same issue.
I tried with Kicad 4.0.2 and now with 4.0.4. Same results.
OS Windows 10.
Instaled C:\KiCad

Any idea?

As a data point… I run KiCAD nightlies (no stables) on 4 Win7 64bit machines, at least no instant crashes (all have dedicated GPUs installed though - as this came up on the bugtracker thread).

There are many recent bug fix commits shown on Launchpad. Several of these affect the 4.0.x Stable build, so maybe there will be a 4.0.5 cleanup soon?

I have found solution on this problem on other similar topic on this forum.
I have removed Python 3.5 and removed PATH, PYTHONHOME from my environments variables.
Now both PCB New and PCB Footprint editor opens :).

1 Like

Non standard Python installations strike again.
I wonder if it is possible for KiCad to be made more robust without doing a complete Python install in the same directory

1 Like

Wow. I’m impressed and happy now. After a long wait, KiCad now works again on my Win 7 64 bit system.



               Paul Brown


There’s nothing smarter than a brain.

browns brain logo colour.png

I used KiCad successfully about a year ago and tried today and both pcbnew and the footprint editor crash before every opening as in this thread. I am a windows developer and when I go to Debug in VS2015, I get this exception: “Unhandled exception at 0x000000000C2D9FC2 (nvoglv64.dll) in kicad.exe: 0xC000041D: An unhandled exception was encountered during a user callback.”

Googling yields very little except that this is an open gl dl.

My environment is Windows 10 x64 (Lenovo W540) with an NVidia graphics card. Note, it did seem to work in the past which is odd.

Any suggestions would be helpful…

I think there is a bug here with either the NVidia OpenGL driver or your use of it. I was able to work around the problem by going into the NVida OpenGL settings and explicitly have the program use the Intel integrated graphics card and not NVidia as per below. NVidia drivers are completely up-to-date as of 6-Jan-2017 and are at version 353.82. I am not sure how one submits a bug, but here you have it. If you would like any more system info, let me know.

Hi Jim,

I think only a few developers monitor this list, it’s mainly users. The place to report bugs, especially crashes like this, is see link at top right “report a bug”.

Unfortunately, the new graphics have opened another avenue of obscure failures, so I am sure we would all appreciate as much as help as we can get nailing these problems. The Intel drivers seem to have caused most problems for KiCad and some other OS projects.

1 Like

One thing KiCad lacks is the ability to select OpenGL features it uses.
You are in a better position to work with the developers to isolate any KiCad OpenGL bug than most of us, so as @bobc suggested, report the bug on Launchpad and take it from there