KiCad crashes every time when opening pcb file

Hi all, I’m new to KiCad and when I tried to open a kicad_pcb file the whole app crashed.
After starting it again I tried to run Pcbnew, same result crashed instantly.
I tried the stable version as well as the nightly build, same result.
Running on a WIN7 64bit PC.
I searched the web and the forum but can’t find anything helpful.
Has anyone got an idea what could cause the app to crash?
Is there a log where I could get some more info?


KiCad version?
Do schematic files open OK?

This is the version info from the one running at the moment but as mentioned I have tried the daily builds as well.
Schematics is fine, the PCB footprint editor crashes the app as well.
Application: kicad
Version: 4.0.0-rc1-stable release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.2.0,wx containers,compatible with 2.8)
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Boost version: 1.57.0

This content does not belong on the forum. Please report a bug and follow the guide lines on

So, it’s been about a year from the original post and the problem is still there. I just installed the newest stable release and it crashes when I try to open the pcb (pcbnew crashes). Schematic opens fine. I am also using Windows 7, 64 bit as with the original person.

I like Kicad. I use Altium Designer at my day job and find Kicad to be almost as good. I would like to keep using it but it needs to work on a Windows 64 bit PC.

I know this bug has been reported but it doesn’t seem to be important. Should I move on or is a fix coming soon?

thanks… also, this forum is the place to discus these types of things/bugs.

Very few people seem to be affected by this. My first thoughts are that you may have a PATH problem, maybe a parallel Python 3 installation or your antivirus doing something wrong

I use kicad in some windows 8 64b pcs, no problem at all…
have you tried to put UAC off?
and/or see if some of kicad exe would need a firewall allow policy?
Control Panel\System and Security\Windows Firewall\Allowed applications

Hi there.
pcbnew crashes with any pcb file and even with no pcb file, if I just open pcbnew.exe.

I’ll try the UAC and the firewall thing but, respectfully, I’m skeptical that it is the problem. I hope it works.

I found somebody else with the same symptoms and he indicated the problem was with Boost libraries.
( Doesn’t mean much to me at this point.

I’ll report back after trying the other suggestions.

I have tried all of those suggestions. No difference.
Works fine on my PC at home, just not at work

Try to delete all the kicad stuff in %APPDATA%.

OK, I’ve tried UAC and the firewall. Neither worked. I’ll now try the %appdata% next.

Deleting the stuff in %APPDATA% makes no difference either

I just tried deleting appdata stuff as well with no difference. After pcbnew crashes it creates a new pcbnew text file in appdata directory. That file only has in it:
file1 =
file2 =
file3 =
Other files are created for kicad but I can’t see anything glaringly wrong with them.

Any other things we/I can try?

There was mention of a possible Python path problem so I uninstalled my Python 2.7, then uninstalled KiCad and then reinstalled KiCad.

This made no difference.
Ver 4.0.1 works on my Windows 10 64bit tablet but not on my Win 7 64 bit PC.

Check your Java version, the KiCad registry entry notices this.
Another possibility is your OpenGL as the pcb component uses it

OK, So these are the latest things I tried:

  • updated Java
  • updated video drivers
  • updated OpenGL

Hmm, still wont work on Win7 64bit. pcbnew and the footprint editor both just crash when I try to open them.

What happens if you open up a command line with cmd, cd to \Program Files\Kicad\bin and enter pcbnew.exe?
On my machine the prompt re-appears quickly, but pcbnew is running

Just in case… running KiCAD on Win7 64Bit here… running fine on 4 machines. Standalone not part of a domain.

I use the nightlies with this ending:

Can you post your systems environment varaible?

  1. Start>ConstrolPanel>System>…
    [new window]
    2)Change Settings for Computer name, domain and workgroup>Advanced Tab>Environment Variables…
    [new window]
  1. in the upper window must be a ‘Path’ entry… copy it’s contents and post it
  2. in the lower window must be some KiCAD/KiSYS varaibles… post them as well

(remove your name/buisness/etc where ever needed before posting please)


C:\Python27;C:\Python27\Scripts;E:\Data_Code\Python;C:\Program Files\smartmontools\bin;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCommon\


C:\Program Files\KiCad\share\kicad\template


C:\Program Files\KiCad\share\kicad\modules\packages3d


C:\Program Files\KiCad\share\kicad\modules

There is another Path variable in the lower window… might need to look at that too… contains a lot of stuff for my system.

There is a free OpenGL extensions viewer called GLView. This will tell you the OpenGL mode and extensions supported.
I ran it on one of my machines and found 1920x1024x32 and full support for version 4.4, partial for 4.5

I can see it opens pcbnew for a flash and then it crashes.