KiCAD 7: Can't set my preferred language

with KiCAD 7 I am unable so set my preferred language. I installed the kicad-doc-* package, but if i try to set my language it says it is not installed. Am i missing something or is this a bug?

Application: KiCad x86_64 on x86_64

Version: 7.0.0-da2b9df05c~165~ubuntu22.04.1, release build

	wxWidgets 3.2.1
	FreeType 2.11.1
	HarfBuzz 6.0.0
	FontConfig 2.13.1
	libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.13

Platform: Ubuntu 22.04.2 LTS, 64 bit, Little endian, wxGTK, gnome, wayland

Build Info:
	Date: Feb 22 2023 09:43:42
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.5.2
	Curl: 7.87.0
	ngspice: 38
	Compiler: GCC 11.3.0 with C++ ABI 1016

Build settings:

for the same system I can confirm this here for the following installation method

sudo add-apt-repository --yes ppa:kicad/kicad-7.0-releases
sudo apt update
sudo apt install --install-recommends kicad

there is no directory /usr/share/kicad/internat/

I’m not on Ubuntu but looking into the PPA I see the kicad-doc-<lang> packages are present:

However, looking at my distro, this is the description of the kicad-doc-de package: German documentation and tutorials for KiCad

Whereas there is a kicad-lang-de package whose description is: German translations for KiCad

So maybe it’s the kicad-lang-<lang> package you should be installing.

There is no kicad-lang-* package available for me

Yeah, I don’t see them in the PPA. Maybe raise a ticket for the Ubuntu packages maintainer to build them?

Just found the “problem”

The same problem in Linux Mint 21.1

If someone is in urgent need of the language, you can fix it with this command

sudo ln -s /usr/lib/kicad/share/kicad/internat/ /usr/share/kicad/internat

Can you try Ubuntu 7.0 testing builds and see if it fixes the problem?

Now it works OK in Linux Mint 21.1. Thanks.

Ubuntu automatic software updater also solved the problem now automatically

1 Like

Current stable solved the problem

Application: KiCad x86_64 on x86_64
Version: 7.0.0-da2b9df05c~171~ubuntu22.04.1, release build

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.