KiCad 6 slow/unusable

I’ve been using kicad 6.0.0 for a while on my windows machine and everything has been working great, even for some large boards I designed with many components but recently it started being very slow to the point where it’s unusable in the PCB editor.

Just opening the preferences window or component properties window takes about 10 seconds. Dragging a pcb track is painfully slow, it basically gets stuck along the way while it tries to optimize the track. Interactive router similarly slow, getting stuck while figuring out the path.

My machine specs are: Windows 11 x64, Ryzen 7 2700, 32GB DDR4, Nvidia Geforce GTX1050 Ti, SSD storage. Graphics card driver is unchanged: Nvidia from 30-sep-2020. Task manager doesn’t show any significant load for CPU/RAM/GPU, all looks normal.

I haven’t noticed exactly when it started being so slow so I can’t really correlate with any other software installed on the machine or settings adjustment to Kicad itself.

I have noticed that for example when dragging a track within an open area, it’s very fluid but as soon as the track hits an obstacle, it starts responding very slow to the point where it hangs.

Things I have tried so far:

  • Updated to 6.0.5 with no improvement.
  • Switching from accelerated graphics render to fallback graphics with no improvements.
  • Enabling or disabling antialiasing makes no difference.
  • Testing with different projects smaller and bigger, no difference.

Any hints on what might be causing this?

1 Like

Not an answer, but maybe these can be related (v6.99 version):

You can try to revert installation default setting by renaming %appdata%\kicad\6.0 folder. Try 8f speed is better with defaults. When retry with faulty settings. In case there is a performance difference, you could do a diff of condig setings to track down the faulty one.

1 Like

Maybe also this:

These kind of bugs are very nasty, and if someone can tell why it happens, it’s very valuable information for the developers.

1 Like

Reverting to default settings by renaming %appdata%\kicad\6.0 folder fixed it. Immediately after Kicad started being very snappy, even opening large projects is now almost instant.

I don’t have that many settings different from default. Just a couple of keyboard shortcut keys and a couple of libraries added extra so I will add those back one by one and check the behavior.


Have you tried to reproduce issue 11592 from the link to gitlab, privided earlier? You mentioned keyboard shortcuts…

It might be instructive if you could diff the old and new config trees.

Same issue, resetting my settings didn’t help. Basically the route optimizer or whatever it’s called causes the program to freeze for 10-30 seconds. Even routing something as simple as this freezes the program, making it barely usable. Is there a way to turn off the optimizer for now?

1 Like

Please adjust settings under Route → Interactive Router settings and see if something can be done to stop this issue (alternatively, Right mouse click over “Route Tracks” icon to access these settings) :confused:


1 Like

Can you check you are using accelerated graphics not fallback

Can you share or e-mail me the board that causes the freezes? Thanks!


1 Like

Run an PCB Editor / Inspect / Design Rule Checker. The Interactive Router may get confused if there are DRC violations elsewhere on the PCB, even if they seem unrelated to the human eye.

Even if this is the cause, it may be a good test case to fine tune the algorithm for the developers…

1 Like (110.8 KB)

Here you go

Thanks! Shove mode works really smoothly

I’m experiencing the same issue: Kicad 6 routing is really sluggish and, more than often, the router is not able to join tracks to pads, especially when using walk around mode. Using shove mode is “slightly” better, but nothing to be proud of…Compared to Kicad 5 performances have become, unfortunately, really bad.

We would be delighted to fix the slugishness issues, but they sometimes quite depend on the rule settings and the particular PCB layout. Could you send us a stripped-down version of the PCB showing exactly the situation where the router becomes slow (or DM me the full layout)?


Is the .kicad_pcb file only sufficient or you need the entire project, project file + schematic file+ pcb file?
It is a commercial project hence, honestly, I would like to avoid disseminate the files publicly…

Design settings are in the project file, so the pcb file alone isn’t enough. You can remove the schematic file, though. Tom W is a KiCad developer, you can send him a PM (private message) and attach the zipped project so that it won’t become public. It’s also possible to create an issue in the gitlab issue database and set it to “confidential” in which case a limited number of trusted people see it.

For investigating router slowness, it is important to have the kicad_pcb, the kicad_pro, and any custom design rules file (kicad_dru) if you use it.

You can create a confidential issue on GitLab also, which will avoid exposing the files to the public.

We prefer users submit confidential issues over DM-ing things to developers in this or other forums, because it allows us to keep track of the fixes that go in (by referencing the issue number)

Find the link below:

1 Like

I get a “404 Page not Fond”, which suggests issue 12067 is flagged properly as a confidential issue.

This does limit the amount of people who can work on it. Sometimes it’s a better solution to remove the confidential parts of a project and them make it public. Such a project does not have to have a “working” schematic nor a PCB layout that makes sense in a real worls project. The only thing that matters is that the issue can reproduced.