KiCad 6 Fails to Save to Synology NAS - Fedora 37

Fedora 37
KiCad can read and load projects from my Synology DS220j but fails when attempting to write/save with the following error messages:

04:35:46 PM: Impossible to set permissions for the file '/run/user/1000/gvfs/smb-share:server=,share=data/000-PROJECTS/delete_me/testing.kicad_sch' (error 95: Operation not supported)
04:35:46 PM: File '/tmp/eeschema3kJfx6' couldn't be renamed '/run/user/1000/gvfs/smb-share:server=,share=data/000-PROJECTS/delete_me/testing.kicad_sch' (error 0: Success)

I can read and write LibreOffice files to the NAS from the same machine (Fedora 37).
There is a Known System Related Issue on the site mentioning similar issues with KiCad saving to a network share but it appears to relate to KiCad 5 and was closed two years ago.

I would appreciate any guidance or suggestions.

Application: KiCad

Version: 6.0.10-2.fc37, release build

	wxWidgets 3.2.1
	libcurl/7.85.0 OpenSSL/3.0.5 zlib/1.2.12 libidn2/2.3.4 nghttp2/1.51.0

Platform: Linux 6.1.8-200.fc37.x86_64 x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
	Date: Jan 14 2023 00:00:00
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.78.0
	OCC: 7.6.3
	Curl: 7.85.0
	ngspice: 38
	Compiler: GCC 12.2.1 with C++ ABI 1017

Build settings:

The issue you are referring to appears to be a windows specific issue, but probably similar in nature. There is also another topic here with a samba share on a NAS, can you check the file permissions as suggested here?

This issue does appear to be related to file permissions. I’m not proficient enough in Linux to understand the details yet but it does seem to be unique to KiCad.
Thank you for the additional information.

Well, it’s either


In the latter case, if gvfs is using smb to Synology which is going to be usnig samba…yea samba is a bug fest that doesn’t work as it should, ever. (Trying a git checkout of a large repo like linux or kicad to a samba hosted drive is a good way to test, it usually fails identically).

You are best setting up a NFS share on the NAS to avoid samba.

Do not use gnome virtual file system.
Mount the NAS using cifs what is handled in kernel directly.

sudo apt-get install cifs-utils

To mount NAS permanent, write mount in /etc/fstab.

jv@JamesWebb:/etc$ sudo mount -t cifs //
/media/netshare -o username=xxx,password=yyy,uid=1000,vers=2.0

See also recently issue 13305 what is a known bug of gvfs

Following up on this, I finally decided to dig into the issue and, thanks to the advice received here and google searches, I think I have it resolved. Here’s what I did:

I created a file in my Fedora Linux home directory with the Synology server login credentials. I named my credential file “.smbcreds”. The file contains two lines:
password=[server password]

I added a /mnt/data /mnt/nas/data directory in my home directory.

I added this line in /etc/fstab:
// /home/[user]/mnt/nas/data cifs credentials=/home/[user]/.smbcreds, uid=[user] is the local ip address of my synology server
[user]=my user name (no brackets) on the synology server
‘nas’ is the network name of the synology server
‘data’ is the shared folder on the server

I can now read and write files to my Synology server using KiCad from both my Windows 10 and my Fedora 37 Linux computers.

19 APR 2023 EDIT - corrected directory name created in home directory


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.