KiCad (6.0) project files encrypted and can not be opened [SOLVED]

Hi, I’m new to KiCad but an experienced pcb cad user.

I have a new schematic and pcb project completed but when I reinstalled KiCad in a new folder it will not now open any of the previous project files. The message “You don’t have permission to open this file” appears. I have tried a large number of Google search suggestions re changing ownership etc but nothing works.

It appears that KiCad is automatically encrypting all the files it generates. Can anyone explain how I can get access or I will have to redo the project.

Also is it possible to use KiCad without it encrypting the files?

First what OS and what version of Kicad? Kicad doesn’t encrypt files as far as I know.

Yes, what OS and KiCad version? Lack of permission doesn’t imply encryption. It could be normal account permissions. I’m pretty sure there is no encryption in KiCad. It’s not proprietary hostageware.

Yes I “fixed” a weird problem in a schematic not so long ago. There was an invisible component far away from the rest of the schematic. I was able to open the schematic file with a text editor and delete the information for that symbol. That was not the only time I have opened KiCad data files with a text editor. I am definitely not a software expert so if I can do this, most others on this forum can do so also.

From the help Copy version data…

Windows 10 x64 (up to date)

Application: KiCad (64-bit)

Version: (6.0.0), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19042), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Dec 24 2021 19:17:02
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

Windows 10, KiCad version (6.0.0)

If I check the properties [Advanced] of all the KiCad files ‘Encrypt contents to secure data’ box is ticked.

Also file properties has a ‘Ownership’ line which when opened says ‘Personal’.

This is only true for the KiCad files. No other files in my Documents folder have this. I have not done anything to enact encryption on KiCad. This is true for a brand new install of KiCad.

I’ve installed an new image of windows 10 and a new install of KiCad.

I have just tested by trying to open the Schematic file in a Hex Editor (HxD).
The latest files from the new install of KiCad and the new project will open okay.

If I try the original project schematic file it will not open and says ‘You do not have permission to open this file’.

I have started to recreate my whole project from scratch, so any help would be really appreciated.

I’m starting to get the feeling that this is a Windows 10 file ownership issue, but why is only KiCad (6.0) being effected by this???

Thanks to you all for your interest.

Well…Some of that sounds like a Windows question which I will mostly direct to someone else. Are you an administrator on your computer? I think that if it is your own computer you ought to be an administrator on it.

But for editors; I would not attempt to use a hex editor and I do not know enough to use such. I think that is probably complicating matters. I used Notepad. Wordpad might also work.

That looks like a Windows thing. KiCad per se doesn’t do any encryption.

According to this tute which I found with the search “windows 10 file encryption”, it seems all you have to do to make the files readable again is to uncheck the box Encrypt contents to secure data.

1 Like

Edit: following post can be discarded, I have missed this info:

If I check the properties [Advanced] of all the KiCad files ‘Encrypt contents to secure data’ box is ticked

Original post, valid for simple permission problem solving:

  1. Open properties of root folder, add user “everyone” with all allowed permissions (steps 1…3 in image);
  2. Go through the list in “Group and user names” and set all permissions to “Allow” for every entry;
  3. Repeat this for all problematic files;
  4. Launch notepad.exe (WIN + R) and try to open problematic file. If contents (readable text) is seen, everything is ok, kicad also must open the files.

In case this does not helped:

  1. Again, open properties of root folder, and files afterwards. Use Advanced button to change Ownership of all files and folders to user called “everyone”. Close these dialogs when done;

    • Also, “disable inheritance” can be set together in step 5;
  2. Again, repeat steps 1…4 from this post for every file/folder;

In case does not help: Have you tried to move files somewhere, and into another PC and tried opening them with notepad?

All in all, you have serious file permission issues, or malware. You should consult with a “local PC guy” if problem persist.

I can confirm that KiCad does not have any file encryption.
Your Windows has optional file encryption, which you seem to have used… I hope that your new image has the same crypto key available

Maybe KiCad is executed with differen windows user credentials? Aka using “run as…”. Is your account of “administrator” type? Don’t you get an uac prompt when launching kicad?

Try running kicad as administrator an save files, try to reopen them.

I have related problem with libreoffice: it cannot write lock files in any directory if not ran as administrator. And I was unable to find solution anything other than going to libre binaries properties → compatibility, and tick “start as administrator” checkbox. Now I have uac prompt everytime lo program starts, but I can use it at least.

If you ever run KiCad as Administrator, then you will get files that cannot be accessed by a normal user.
There is no need to ever do this.

Yes, this is my PC and I am the Administrator. The reason for using the Hex Editor was just to test whether I would be able to open the file, which I wasn’t, but the new project files I was. The Hex Editor should open any file without problems. Windows is stopping me from doing anything with the files. I cannot even copy them???

Thanks for the link, but I have tried that and it comes back saying the ‘File can not be decrypted’.
I tried it again and same result.

I’m thinking that even if this is a windows caused problem, it is possible for this to effect KiCad and it could happen to anyone, so is worth pursuing to get an answer.

Thanks for the suggestion and nicely presented process poco. I have tried that multiple times without success, but I will go over it again because I didn’t disable inheritance, which other processes didn’t mention.

I think this is getting close to the answer. Win10 asked me to backup a ‘key’ after KiCad install which maybe I didn’t do first time as I have never seen or been asked that before and the new win10 image would not have that key.

What is odd is that no other software has asked me that, no other installation or files are a problem and I have never set win10 to enable any type of encryption. I have all the standard malware protection enabled and no other problems.

Only the original KiCad files are effected.

Did you copy the files from a previous Windows system? I think somehow you enabled encryption on your project directory without realising it. You were able to continue working with those files because the decryption is transparent as long as those files stayed on the computer with the key, the idea being that they would be protected from being copied out of your computer. This encryption isn’t specific to any application.

The howto I found doesn’t mention any passwords, so it would rely on an automatically generated key on that computer. If you didn’t copy over the key to your new system, then you have lost access to those files. Do you still have your old system?

Currently KiCad is operating normally as it originally did so I can generate and save files okay, and I am able to rebuild my project. My account is Administrator type.

The problem is all my original KiCad files I can no longer get access or open in KiCad. I would really like to get access to the original files and also find out what happened so I can guard against it ever happening again.

I think this is getting close to the cause of the problem. I hope this will help, I will describe in more detail how I was setup when the problem occurred.

This is how I have setup my operating environment.
I have 3 partitions.
C: for the Win10 operating system
D: for all my libraries, Documents, Downloads etc and Portable apps.
E: for system backup images.

I like to keep my system as simple as possible so every 6 months or so I reinstall a previous clean image of win10, update it and save a backup of the new win10 image.

The reason for keeping all my Libraries on D: is when I reimage win10 all of my portable apps and Documents are intact.

Some months back I wanted to change the PCB cad software that I had been using for years and I tried a number of alternatives. I really liked KiCad and also the fact that it was open source.

I installed it and completed a relatively small project as a trial and got to really like KiCad.

At this point I had a number of alternatives installed and I wanted to get back to a clean system, not just uninstall them, so I reimaged my Win10 from my last backup, updated win10 and reinstalled KiCad and then took a backup image.

When starting the newly installed KiCad none of my previous KiCad files would open. I was surprised to see again win10 ask me to backup a key after installing KiCad which I did.

I think that maybe a system encrpytion key being used as part of the KiCad installation was only held on the previous installation and with reimaging it is now lost.

If this is the case it could be quite serious and I would really like to confirm it, so any help is greatly appreciated.

Thanks every one for your input.