KiCad (6.0) project files encrypted and can not be opened [SOLVED]

I don’t think KiCad has anything to do with it. KiCad doesn’t trigger any encryption services, enabling encryption on a folder would have be done by the user. I hope nobody else had access to your computer and did this to you.

Unfortunately the outlook is bleak for the recovery of your files, according to this Microsoft forum query:

Thanks for the link, that is very close to the situation. I think I am now resigned to the fact that I have lost my files. The issue now is how did this happen, I didn’t do anything different to any other installation.

You may be right but,

I am the only person who has access to my computer,
I didn’t enable any encryption,
It has only affected my KiCad files,
On the new win10 and new KiCad install I was still asked to backup a key???

What I will do is start completely from scratch.
Reimage to the last win10 non KiCad.
Reinstall KiCad and save a simple test project,
Take careful notes as to the exact procedure.

Then start again from scratch as above and see whether KiCad can reopen the previous saved files.
If I can’t then there must be something about the KiCad installation which is causing this.

I will do it now and let you know how it goes.

If you can restore the old OS image, including the keys, you should be able to disable encryption on the project folders and the files can then be read elsewhere.

I’m guessing that happens when the Win10 installer detects that a key exists (may even be specific to the folder protected) but it could have been any application, just happened to be KiCad.

One possibility is at some point you used a portable hard disk or flash disk and Windows asked you if you wanted to protect the files from copying. Without the key in the system, a thief cannot read the stolen files.

KiCad is open source, you can check the source to see if there any use of OS specific encryption. I don’t think you will find any. Encryption is a concern outside of KiCad. AFAIK you’re the first one to bring up encryption.

Unfortunately I did not save an image of the OS that had the KiCad and all the other pcb cad test installs. I would not normally do that as the purpose is to get rid of all the other installs and generate a fresh OS and fresh install of KiCad. I have never faced a situation like this before.

I have tried this on the original files and it will not let me disable encryption.

I have just reimaged my win10 OS to the previously backed up image made prior to me ever installing KiCad to start from absolute scratch.

I have then installed KiCad on the new system. It did not ask for a key. I did a really quick KiCad project and saved it to Documents. It would open and operate exactly as would be expected.

I tried opening the previous original project. It would not open. That was expected and is the problem.
I reopened my current new install test project and that opened normally.

I then looked at the properties of the new test project and all are encrypted. I tried unchecking the tick box and it would not allow me to do so. This has only happened with KiCad and everything here is a new install.

What I will do now is go around the circle again and reimage the OS and reinstall KiCad to check if I can open this new test project. I expect that I will not be able to do so. I think something is KiCad version (6.0.0) is causing this.

I won’t be surprised if you cannot open it with a new image, but it may not be KiCad (or any other program). It may simply be that during your Windows install or account creation you have chosen or allowed for your Documents directory, and everything underneath, to be encrypted. As I understand it encryption can be made to apply to all descendant folders.

Before blaming KiCad, you should also try to create some documents with other apps in Documents.

I have tried creating and saving documents with other software before and with this brand new install. No problems anywhere and no encrypted properties either. KiCad is the only addition, and it only happens with KiCad files. ???

Well feel free to file an issue on Gitlab then, but I’m pretty sure KiCad doesn’t do any encryption. My money is on the hidden intricacies of the Windows OS.

Did you use the same project folder for the other PCB software, that may encrypted the folder?

Did you made any backups to a external drive? Can you open them?

As far as you know now. Have you gone through all the files on your old and new computers?

It’s 100% guaranteed that KiCad doesn’t do any encryption. You can read through the source code to be sure if you want to, but KiCad has nothing to do with this.

1 Like

Have you scanned you system for malware. Something is certainly strange going on with your system.

1 Like

I think you are right. I have just done one very telling test. I created a new folder outside of KiCad to in which to start a new project and it’s properties were marked as encrypted. This process had nothing to do with KiCad so it must be a system issue. The reason that KiCad seemed to be causing this was that everything else was normal, but this was because KiCad was also the only new installation.

This morning while doing some other tests outside of KiCad I got the momentary message “EFS UI Options etc”. I now know from one of the posted links, that this referring to a type Win10 internal encryption. Why this has just started I have no idea, but it was the cause of me loosing my first project.

I will still pursue this to find out exactly how this has occurred to help avoid it ever happening again and also to help others avoid it.

I will post the results here.

Thanks to everyone who contributed to this. I’m sorry that this ended up not being a KiCad issue, but that is probably a good thing.

I did not use the KiCad folder for any other files but I did test creating a new folder and yes that was also encrypted.

Yes I have backed up my whole D: drive to an external drive and yes, unfortunately the KiCad files are also encrypted and can not be opened.

I have checked all backups and only KiCad files are effected thankfully, but KiCad is also the only new install. Something changed just prior to me using KiCad and at this stage I do not know what it was.

Thank you for this. I now am convinced that this is the case.

Yes, no problems anywhere. It now appears that a win10 security setting has changed re EFS and I don’t know what. I will try to find out and post the results.

Here is a very brief summary of what occurred and the cause of the problem:

At some stage just prior to installing KiCad my Documents-properties-advanced-[Encrypt contents] to secure data] must have been ticked. (I still don’t know how this happened)
I then installed KiCad and created and completed my first project.
I reimaged my win10 system disk to go back to a clean win10 system and reinstalled KiCad.
When opening the new KiCad no KiCad files were accessible.
The encryption key used by win10 was stored on the previous win10 image and lost when reimaging.

Fortunately there has been no other effect other than me loosing all my first KiCad project files and now all is back to normal. Fortunately also it wasn’t a big project and I can redo it as good training exercise for KiCad which I really like.

An open source project like KiCad along with an active and constructive help forum is a huge asset.

Thanks again for all your contributions.


Cosmic rays flip bits. Hardware can ‘skip beats’. Just glad it wasn’t disastrous.

1 Like

Play it safe like I do. Have a backup. And a backup of the backup. Also a copy. And a copy of the copy. Then a copy of the backup. And a backup of the copy. In both plain and crypted versions. :rofl:

On three different drives, one being external, like good ol’ paranoid me… just can’t trust these new fangled computer devices :crazy_face:

No off-site backups in case your house whole burns down?

There are also other factors that can affect everything in your house at the same time, such as burglary or flooding (in some area’s) or other natural disasters.

Off-site backups are a common strategy for companies for anything IT related.

S#@t!!! never thought of that! :confounded: