KiCad 5 copies project's fp-lib-table to global fp-lib-table


#1

I installed KiCad 5.0.2 on Ubuntu using the PPA given on the website:

sudo add-apt-repository --yes ppa:js-reynaud/kicad-5
sudo apt update
sudo apt install kicad

This is on a machine which did not previously have KiCad. (So there should be no issue with migration from v4, etc.)

I then opened an existing KiCad project. When I ran CvPCB, KiCad popped up a dialog stating that it had either given me the standard kicad footprint libraries or an empty fp-lib-table.

None of the standard KiCad libraries showed up in CvPCB. I found a FAQ entry, but when I tried doing sudo apt-get install kicad-libraries and sudo apt-get install kicad-footprints, it said those packages were already installed.

I took a look at ~/.config/kicad/fp-lib-table, and it had not quite given me an empty fp-lib-table. Rather, there was a single entry in the fp-lib-table, which was a local library in the project I had opened. It turned out that the new ~/.config/kicad/fp-lib-table that KiCad created for me is identical to the local fp-lib-table that was in the project directory.

Why did it do that, and how do I make it give me the default libraries instead?


#2

OK, I seem to have solved it. I deleted ~/.config/kicad/fp-lib-table, then I created a new, empty project, and ran CvPCB in that empty project. Then, it created a new ~/.config/kicad/fp-lib-table for me with all the default libraries.

So moral of the story seems to be, don’t run KiCad 5 for the first time on an existing project (at least, not one with a local fp-lib-table).


#3

This might be a bug. Care to report it on the bugtracker?


#4

I agree. In any case I tried something similar - when I start from scratch KiCad asked what to do with sym-lib-table but gave only that ambiguous information about fp-lib-table. I think they should do the same thing, whatever it is. And the information about the action should be more exact. KiCad can certainly know what it actually did and should not let the user guess.


#5

So I did a little more testing. It isn’t exactly that it copies the current project’s fp-lib-table; it’s that it copies the fp-lib-table from the current directory. These happened to be the same in my case, because I was in the project directory when I typed kicad &.

Still seems like unexpected/undesirable behavior, though.


#6

I have reported it now.