KiCad 5 - 3D file paths

Hello all,

I am having problem with the 3D components not being displayed in the 3D view of the PCB. I have so far traced the problem to the path in the footprint properties being different than the actual path of the 3D files. When i manually add the path, 3D file shows up as in pic. 1st path is added by software whereas the second one was added by me manually.

There is subtle difference in the paths (capacitor and capacitors). Seems like the software installs files in one path but the path it uses it to seek is different. How can i resolve this?
For one component i could change the path manually but for hundreds?

I should mention that i had KiCad 4 installed before i installed 5. I am using Windows 10.

I have tried reinstalling the software multiple times on different drives without solution.

In v5 footprint libs were renamed to be singular (Capacitors -> Capacitor). So it appears you are using footprint lib from v5 but your 3d models are still in v4 path.
Do you still have v4 installed? Check where KISYS3dMOD points to in Preferences->Configure paths in main KiCad window. You probably have to update that to point to v5 install.

Well the path is pointing to the correct directory in preferences. However i just noticed that when I click to add a symbol in eeschema and the software loads the libraries, it does so not from local cache but instead it fetches from and not from How do i force it to use the new folders from Github?

I was mistaken in previous post, it’s the other way around - you are using v4 libs and v5 3d models.
Same issue with you schematic libs.
Essentially remove all your libs and re-add them from correct paths.

1 Like

Read this: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

1 Like

Oh yes. That solves it. I just deleted all library paths in cvPCB pointing to Github and added all the local paths.

However i wonder in spite of uninstalling KiCad 4 how these paths remained the same for cvPCB? i had even checked registry and deleted all entries related to KiCad!

1 Like

The user settings doesn’t get changed during an upgrade. Unfortunately, the complication is because the tables that KiCad uses (all of KiCad) is part of the user settings (to allow for adding user libraries). So when you upgraded to v5, the reorganized v5 libraries came along for the ride. But the library tables still pointed to were it was expected to find the v4 libraries. One of the things that changed with the reorganization was a change in the library names to remove all plurals. Another was to have the standard libraries local, not served by github. (That experiment failed so it was dropped.)

On Windows, the offending file is: %APPDATA%\kicad\fp-lib-table
Wipe out that file and KiCad will copy the standard library version from the install to appdata. But that will wipe out any personal libraries that the user may have in the table, as well as re-enable any standard libraries that the user removed from the table to streamline loading of the libraries.

I’m beginning to think that a python script is needed to intelligently parse the library tables (both the from the install and the user global table), show the user the changes to any libraries in the standard locations to offer the user to update them, but leave the user library entries alone. Do this for both the footprints and the schematics, launchable from both the command line and the action script menu. The difficult part (in my mind) would be how to determine, in an OS agnostic way, where the two sets of tables (what came with the installer and the user settings folder) are…

I did something very much like that… kipi

It doesn’t use the data installed with KiCad, because that is impossible for the script to know unless the user types in the paths to the data. Instead it uses downloadable content packages which have an associated manifest file.

I didn’t write an Actionscript version, a problem with that is it requires a restart of KiCad to reload cached data. It would be really easy to add an API in KiCad to refresh caches I think.

That’s right, and that should have been in 5.0.0.

I have the same problem. Having updated from V4…V5…Nightly, none of my footprint files reference valid 3d models.
It seems I need to del that file and have it reload, although I’m QUITE reluctant to do that right now. It would at a minimum, be nice to have a warning to tell you to be aware of the problem. Wouldn’t nearly 100% of users just upgrade and fall in the same hole?

Read this: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

My work flow is that, using my own collective libs, and having 3D mode files relative near the footprint library so that I can use relative path to point to 3D model. This way, doesn’t matter which KiCad version I’m having (event have 5 of them installed in difference C:\Program Files\KiCad_vXYZ. still work fine). Using relative path is much more portable to me than using the Environment variables (but most people don’t agree with me on this).

Sorry for my bad english.
I have similar problem.
All libraies work fine except for 3D models.
Any 3D models display in 3D view.
Windows 10 pro on drive C: and Kicad 5.0.2 install in other drive like D:
I un-isntall and re-install Kicad on drive C: with none change in install options but the problem not solved.
I remark that the final path of 3D models have a slash but the other none.
So i hope my english is not to bad.

Did you check the link i shared in my last post?

Thank for reply.
No V4 of Kicad, only clean install V5.0.2.
Yes I read your post and delete my fp-lib-table in my local home.
My problem is just for the 3D models.
The path work with FreeCAD + Kicad setup wb

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.