KiCad 5.1.7 crashes

I remember something about KiCad getting confused by some error in the configuration files, and deleting them (rename, backup, etc) may help.

A quick search:

Coughs up:

If this helps then more info about those configuration files will be interesting.

I am using the latest RADEON Adrenalin drivers for the RX580 on the computer from which I’m writing just now. The other (old) computer where this defect happens, uses another old RADEON card (5450 if memory helps me) and the only usable RADEON driver is the legacy one, no more updates from years; but KiCad has always worked fine on this computer too. Unfortunately, I cannot remember exactly when it started to happen. Since I haven’t installed 5.1.8 yet, I will try later to see how it will go.


thank you, I’ve already read that post but, as I’ve written in my original post, I have tried to completely remove and reinstall KiCad to no avail. Moreover, Eeschema and PcbNew crash (more correctly: disappear) 99.9% of the times only when I click the Save button; but the schematic or pcb are correctly saved (luckily).


ok, I have installed (updated) 5.1.8 on the first computer and all seems to work properly now. I will check again in the next days to see if this problem has gone away for good.

Thank you

well, I’ve spoken too early. The problem is here again as before…


I had similar problems and discovered:

• Running the Stand-Alone versions of PCBnew and Eeschema always crashed and closed if I did not place footprints/symbols (in other-words, if I simply opened them and closed them, Crash.

This did not happen if running them from the Kicad Main Panel.

• In another post (here), I suggested solving slow speed of loading footprints. It turns out, the same ‘observable’ aspect part of the solution (for me) appears to also take care of this problem (can now close without adding footprints/symbols - No Crash!)

Before doing anything, I suggest running “”, not PCBnew or eeschema standalone’s. The Main Panel presents PCBnew and Eeschema Icons to run them…

unfortunately, I always use the main panel; there is no reason for me to call Eeschema or PcbNew directly unless I have to. I also have the habit to run KiCad with its desktop icon, and not by clicking on a .pro file. After opening the main panel I open the project from there.


Do you have ‘Write’ permissions for the File/Folder/Dir you’re saving to?

of course I have. Most of the times KiCad disappears, but sometimes not.


Are the drive you’re saving to local ? There has been issues reported when network drives are used.

… intended for debugging, not for fixing…

• Look at the folder contents of a Successfully opened/saved and Quit project.

What files are in the project after quitting?

Compare to a Failed project…

EDIT - Adding clarifying info:
• Open Kicad, Create a new project
• Run PCBnew from main panel
• Add a Footrpint (Just go through the motions of it but, don’t actually place it on the board or, if placing it, delete it, cancel adding it. File>Save_As_Copy (don’t rename it)
• Do same for Eeschema
Quit Kicad and look at folder contents - what are the files added?

no, it is a Synology NAS but, as already wrtten, sometimes it happens, sometimes not. The path is in UNC format.


ahh… there’s a reason I asked about permissions but didn’t go further.

An old post of mine talked about filenames and the Encoding and Kicad NOT liking any other than UTF-8. I kept having access problems… Until I fixed that (and, Don’t use graphic text characters! like bullets… etc. Keep the name unified (no spaces)

link to the mentioned post

project name: Prova. The files in the folder are the usual ones:
Prova.sch (no components added)
Prova.kicad_pcb (no footprints added)

Strangely, making a “Save as” without renaming in PCB triggered the overwrite confirmation request, but didn’t produce a .bak copy, that instead happened with Eeschema. A bug?


KiCad has some NAS related trouble:

Windows Specific Issues

Network Shares

Editing projects located on Windows networks shares provided by samba servers (non-Windows Server, i.e. Synology, FreeNAS) may result in crashes due to samba generating bad file change events and our cross-platform toolkit asserting the invalid event rather than ignoring it. Windows Server hosted shares should not encounter this issue.

You will have to work on a local drive if you encounter crashes working from a network drive for now. More details can be found in GitLab Bug #5740.


Probably not a Bug, just the way coder did it.
EDIT - Notice the Bak file is sch-bak… The hint is sch=eeschema and fp=footprint.
Footprints are used in PCB…

So, you discovered the files and they’re now in the folder. You should now be able to use without problems. Does it work?

If you use a Template, observe the files and ensure the two Cache files are present…

I have read the post, but it doesn’t concern to my case. I only use characters [a…z, A…Z, _, -] and maybe some other allowed non alpha characters for project names (Windows 10 environment). The particular project of which I’m talking about in this post is named CPU001, so no spaces either, but the “full path” contains spaces:

\FILE_SERVER\cartelle_comuni\Documenti personali\Elettronica\Progetti\ANNIBALE\Schemi\CPU001\KiCad

Now I cannot rename the “Documenti personali” folder otherwise I should change a myriad of projects and library paths. But could it be “that one and only space in the path” the cause of the problem?


get rid of the Spaces in the Path!!! (I see only one but, it takes only one Terrorist to ruin your day

oh, I see. But it happens that when I add or modify libraries and footprints that are located in the same base folder, but some subfolders behind:

\FILE_SERVER\cartelle_comuni\Documenti personali\Elettronica\KiCad\sb\library

KiCad never closes itself. It happens only with projects. Very strange indeed, isn’t it?


aaaaaaaargh, I have to change the whole world! :slight_smile: I haven’t only KiCad under “Documenti personali”… I’m not in a hurry, so it would be preferable to wait a fix for this. Is it possible?