KiCad 4.0.7 footprint library wizard


#22

There is no real centralized place for that. For existing projects you would need to change it manually. For new projects you can change the global template file. It is found in the kicad system directory in the template subfolder and is called kicad.pro.

Or you setup a master project that you copy around instead of creating a new project using kicad.


This is one of the things that will get a lot better with kicad 5


#23

I hope so @Rene_Poschl I’m fairly new to KiCad so errors or problem fixing like this makes my gears grind. I hope KiCad fixes this soon so everybody can just use it without having to change things in order for it to work.

Will things like this also get fixed in KiCad 5 ?


#24

Do I just replace the Kicad.pro file with the Symbol lib ?


#25

Yes

No. it is a bit more complicated than that.
The kicad.pro file holds a list of libraries that will be added automatically to new projects. you would need to update that list.
The kicad.pro file also sets up the default symbol library search paths. You would need to update that if you place the new symbol lib somewhere else as the old system lib.

As this is a frequently asked question i will do some experiments and post something to the FAQ shortly. (Give me an hour or two.)


#26

Ok i played around a bit.

Step by step explanation.

  1. bacup the kicad.pro file (make a copy somewhere where you remember it later)
  2. copy the kicad.pro file into a temporary empty folder somewhere inside your home directory.
  3. open that project like you would normally open any project
    1. start kicad
    2. click open project
    3. navigate to the folder containing the copy of kicad.pro
    4. click on kicad.pro and click the button “open” (or double click on kicad.pro) This might be different for different operating systems.
  4. start the part library editor
  5. preferences -> component libraries
  6. In the bottom half add the directory containing your libraries to the search bath.
    1. click the lower add button
    2. navigate to the directory holding your .lib and .dcm files
    3. click open (without anything selected manually)
    4. KiCad will ask if you want this path to be added as a relative path. Click no.
    5. Make sure the correct directory has been added to the search path
  7. delete all libs from the upper list. (click on the top most lib name, click the upper delete button until the list is empty)
  8. in the bottom most field click on the recently added search path (it should be highlighted)
  9. click the upper add button.
    • if the selection of the search path worked you should now already be in the correct location, otherwise simply navigate to the directory holding the .lib and .dcm files.
  10. Add the libs you intent to have in every project. (The backport lib has 180 libs. I think kicad 4 has a limit of < 100 libs. So choose well.)
    • selecting libs is done by holding crtl + left clicking
    • when all intended libs are selected click open (might again be different in your operating system)
  11. when satisfied press ok in the component library dialog.
  12. overwrite the global kicad.pro template with your modified version (You will need administrator privilege for that step.)

#27

@Rene_Poschl On 3 do you mean part library editor?


#28

this is what i’ve done so far, is this still right ?
I have to delete this right ?


#29

Oh i forgot to add that you should not use a relative path for the user defined search path.
Delete that one and re add it. Only this time when kicad asks if you want to have it as a relative path tell it no.


#30

alright i will do that :+1:


#31

KiCad did not stop me from adding all libs, so i added all libs in my modified version.

Now i just need to go to the KiCad.pro file ( not the copy ) and replace it ?


#32

Yes. After you did that create a new project and test if it worked. (Also test if it indeed added all 180 libs to the new project. Maybe the limitation is found in that step.)


#33

i will try right away :+1:


#34

@Rene_Poschl No luck still the same result as before :sweat:


#35

In the new project you created as a test, did you get the new libraries in there?

For old projects you would need to repeat the process of adding the libs manually. (So instead of working on the copy of the kicad.pro file you directly work on the project file in question.)


#36

It’s still not working. I want to select Housings_SOIC but i still can’t see the different housings.


#37

I don’t know, I find KiCad very unstable on some fronts. I have heard so many people on different forums talking about problems with their libraries and Cvpcb and such

I sure hope KiCad 5 will be beter. I can’t work with a program that’s not working entirely.
I mean some errors I can fix but this is like i have made KiCad and i have to manage the library data. :roll_eyes:


#38

And yet so many people have no trouble whatsoever. You happen to have the “Filter Footprint List by Keywords” filter selected. Try selecting “Filter Footprint List by Library”.


#39

@1.21Gigawatts I understand that many people have no troubleshooting at all, but it would be nice for newer user ( like me ) to just start working without errors. ‘‘Filter Footprint List by Library’’ It does nothing I don’t even get a list with footprints that could fit with the 7555 timer.


#40


#41

What’s strange is that you still have the old Housings_xxxx libs in the list even thought you mentioned that you installed the version 5 backport libs.

And as you mentioned you are behind a proxy this might explain why you have trouble
You might want to take a look at this faq topic as it explains in detail how to install a specific library version locally: How can i install a specific version of the footprint library?


But regarding footprint assignment have a look at this FAQ article: How can i assign a footprint to a symbol?