KiCad 4.0.7 footprint library wizard


#1

helle everyone,

in order to get my KiCad working again ( i tried everything on this forum ) im now on the solution as how to solve it. But the problem is my footprint libraby wizard won’t allow me to select my local files ( copied from this forum ). I’m on a old pc with windows xp 32 bit and it works fine for the rest of KiCad.

How do i fix this ??

image

greetings,

Jasper


#2

As for my file ‘‘lokal library KiCad’’ its containing all the .pretty files


#4

Click on the drop down menu that is currently labeled “All supported formats”.
What does it say?

Also how did you get to the dialog in your screenshot? (You never told us what you did to get there.)


#5

this is what it says :

image

well i did go to the footprint library wizard to set my libraries on local. i wanted to click te local map i have made with all the .pretty files but i cant click next. ( this is all based on what i’ve red on the forum about the cvpcb error that also occurs on my KiCad 4.0.7 ).


#6

and i’m on my work so i’m probably on proxy. ( i use KiCad only for my work )


#7

Ah now i understand (for some reason i thought you where talking about something completely different. I thought you where talking about new footprint from wizard tools. Lack of coffee is a bad state.)


Assuming the “local library KiCad” folder contains the footprint libraries. Click on the plus next to it to show the contents.
Then you should be able to select all the .pretty directories you want to add. (left click on the first one, scroll down if necessary and left click on the last one while holding shift. You can also use crtl plus leftclick to select only some specific libs.) As soon as you have selected at least one .pretty directory the next button should get clickable.


#8

haha yeah coffee helps a lot ! i will look if your method works. either way thanks !


#9

It works only some .pretty files won’t work : Enclosures.pretty, Connectors_Amophenol.pretty, Housings_PGA.pretty, Relays_smd.pretty, Terminalblocks_Phoenix.pretty and Terminalblocks_wago.pretty.

I don’t know if i need these files for my work later. Is this an easy fix to get those files working again ?


#10

All the other ones work fine now :+1:


#11

They might contain footprints that have unsuported features in them. (Might have features from kicad 5)

The library names seems suspiciously like you downloaded the official version 5 library (or parts of it) and tried to add it to kicad 4. There is a backport of said library intended to be used in kicad 4. More details see: Kicad 4.0.x backport release of kicad v5 library is now available on github.

You can also manually run the check compatibility script. Details see: How can i install a specific version of the footprint library? (Second entry)


#12

I will try that another time. ( im fairly new to KiCad but it looks like something I could do ). thank you very much @Rene_Poschl for helping me finding my way in KiCad ! :smiley:


#13

I’m trying you solution today and it’s working. I only get 2 files that i cannot open : CMakeModules and Sources ( i don’t know if these are important but it seems fine by me for now ). :+1:


#14

Only the .pretty “files” contain footprints.
The Sources directory contains freecad sources for footprints that have been created using freecad plus kicad-stepup and the CMakeFiles directory holds the stuff needed by the packagers.


#15

You folder must have " .pretty" format with all your footprints inside. You can add one folder per time.2018-06-13_1


#16

Or multiple at once as i already described in my answer above.


#17

So everything works now i can run Cvpcb and assign footprints and such. ( that was my goal here )
But there is ( Yet :roll_eyes: ) another problem. I can see most libraries and footprint files and asign them.

I have made a 7555 timer ( It’s already in KiCad standard just wanted to try making my own part ). But for some reason i cant see the option for the SOIC Housings and my Housing_SOIC file is just in my library.

I don’t get in anymore :sweat_smile:

Can you help me again?

Greetings,

Jasper


#18

@KsenijaG My folder has only .pretty files im just missing the 2 i mentioned earlier.


#19

If you installed the backport lib (or the v5 lib) then you have the reorganized libraries. This means the Housings_xxxxx libs are now called Package_xxxx

For this reason you should really install not only the footprint libs but also the symbol libs from the same release.


#20

Yeah i have installed the backport lib, I will try to download the symbol libs as well.


#21

How do I change the old Symbol lib with the new one ?