KiCAD 4.0.6 error, wxPython mismatch under Ubuntu 16.10


#1

Hello, I tried to open PCBnew and I am getting this error.

Already updated My kicad version to 4.0.6 by using this command:
sudo add-apt-repository --yes ppa:js-reynaud/kicad-4
sudo apt update
sudo apt install kicad

Can anyone tell me how can I remove this warning message?

Thank you.


#2

What is your operating system?


#3

My Operating system version Ubuntu 16.10,


#4

I changed your title in such a way that others who have ubuntu can see that you need their help.

In the meantime: You can try to reinstal or update wxpython. (This is a shot in the dark.)


#5

I remember that a few months ago 16.10 wasn’t building until a patch was applied due to a library conflict. This could be the same thing again


#6

I’m getting this on Debian (testing release) too. It used to print this error message to the console on startup; now it’s showing up as that pop-up window.


#7

Raise a bug report. I don’t have a 16.10 machine myself yet


#8

Does it affect anything? It just showing me a warning first time I run kiCAD, but I am able to do all the task.


#9

This is the stable release, not a nightly. Even warnings like this are not acceptable


#10

This is the thread about problems building 4.0.5 on 16.10


#11

I created a report
https://bugs.launchpad.net/kicad/+bug/1671671

Paging @vatsal_naik and @David_Bridgham
Please add details from “Copy version info” to this report


#12

@davidsrsb, I tried to software update now I am running 17.04.1 but it didn’t solve the problem. Tried to install wxPython 2.8 version but somehow repository is not working.

I updated the version information to the link you gave in one of your previous post.

I really appreciate your help!
Thanks.


#13

Maybe we should report Jean Samuel @jsreynaud

He is the package maintainer and always eager to help.


#14

@vatsal_naik "could you try to get the package version of wxpython3.0 and wxdgets3.0?

I think you can use something like:
dpkg -s | grep ‘^Version:’ "


#15

@davidsrsb I tried to get a version of wxpython3.0 and it gives me this:

:~$ dpkg -s wxpython | grep ‘^Version:’
dpkg-query: package ‘wxpython’ is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

Then,
I tried this command:
:~$ sudo apt-get install python-wxgtk3.0
Reading package lists… Done
Building dependency tree
Reading state information… Done
python-wxgtk3.0 is already the newest version (3.0.2.0+dfsg-3).
0 upgraded, 0 newly installed, 0 to remove and 34 not upgraded.

Thanks.


#16

I’m having the same issue on KiCad 4.0.6 stable, Arch Linux.

Application: kicad
Version: 4.0.6 release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1010,GCC 6.3.1,wx containers,compatible with 2.8)
Platform: Linux 4.10.2-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.63.0
Curl version: libcurl/7.53.1 OpenSSL/1.0.2k zlib/1.2.11 libpsl/0.17.0 (+libicu/58.2) libssh2/1.8.0
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
USE_FP_LIB_TABLE=HARD_CODED_ON
BUILD_GITHUB_PLUGIN=ON


#17

Odd, because the developers have been pointing the finger at Debian and Arch is a rolling release distribution without Debian origins


#18

From Launchpad
“The same warning occurs on Arch since an update a few weeks ago. It’s probably to do with the distro’s WX packaging. In Arch’s case, the wxpython package hasn’t been rebuilt since 2015, whereas wxgtk was rebuilt in January.”


#19

The package is wxPython - note the uppercase “P”