Keyboard Shortcut X can be dangerous!

When working with a PCB layout and routing tracks I am always having the schematic editor open. If I use the mouse and click on a symbol in the schematic editor to get the PCB footprint identified and highlighted and then move the mouse directly to the pad were I want to start routing a track and press X on the keyboard, the schematic symbol is immaged and the track is not started! This is extremely dangerous!
Can something be done with this? And may be it has been discussed before but I can not find anything about it.
Kjell Karlsen

Why press “X”?

Hotkeys are listed in preferences / preferences.

If you keep pressing X when in the schematic then just change the hotkey.
Luckily there is always the undo key. Ctrl-Z

KiCad has many shortcut keys, and they will have unexpected results when pressed accidentally or in the wrong program. You can for example also change the grid origin or size with a single keypress.

I do not see why you classify this as “extremely dangerous” though. Accidentally mirroring an schematic symbol is easy to fix. KiCad does make automatic backups, but besides that you should have some more reliable backup strategy in place. My normal strategy is to zip up a project each time I’ve done some significant work on it, and then copy it to some external device, just in case my whole PC collapses at some unexpected moment.

An additional strategy is to have some kind of (written) checklist of things (and their order) to do before you generate gerber files, such as a final visual schematic check, ERC, [F8] to update the PCB form the schematic and a DRC for the PCB. Even if open wire ends would not be flagged by ERC, it’s quite easy to spot when looking at the schematic.

Yes, and Hotkey X is used in PCB to start routing a single track and in Schematic editor to mirror the symbol horizontally. The only way to avoide this happening (as far as I have found out) is to Left click on the PCB editor BEFORE using hotkey X to start the track. But I have forgotten this sometimes and left the schematic symbol mirrored horizontally. It get dangerous if the schematic symbol is symetrical with say 8 pins on each side. Yo will not discover this yourself without checking Pin after Pin.The schematic editor reports no fault after the mirroring so the layout is totally wrong and not seen by the last PCB checkings. I am usinh Windows 10 and KiCad v.6. I believe the problem might be that Windows does not focus from the schematic editor and over to the PCB editor when the mouse is moved, therefor I now left clicking before using any hot key.

KjKA

The feature you might be looking for is ‘focus follows mouse’.
I am no windows expert, but I am quite confident that this can be enabled somewhere in windows or with an additional software (XMouseControl).

1 Like

I suppose that it was not noticed by anyone because may be no one works that way. I am opening schematic and pcb windows together only for a moment when I am doing the first division of elements into groups. And during that I am with mouse all the time at pcb. I just point with mouse footprint by footprint and seeing in schematic where it is I move it to right group (taking much more space than pcb size will be. Then I close the schematic window - it is not needed any more - everything I need I have in rats-net lines.

I also quite often have both the schematic and the PCB open for cross-referencing. It is also explicitly designed into KiCad. You select an item in the schematic, and the PCB editor pans to the footprint of that symbol.

I also quite often have the schematic open just for reference. If you type for example: “tr5[Enter]” in the PCB Editor, then R5 will be attached to the mouse cursor for easy placement. And of course I knew I wanted R5 by looking at the schematic (which can also be a printout if you have a small monitor).

1 Like

I have been working with different CAD programs for >30 years and from the moment that it was possible to have both the schematic and PCB layout open on two different monitors I have used it. The program I used most of the time was Ultiboard V.5.71 but I also used Altium Designer but the cost of it was too high for me when I retired so when KiCad 6 apared I started using it and find it very good except for some small problems that are possible to live with when thay are discovered!

I would say the exact opposite, all people I know who work with KiCad (small sample size) work with Schematic and Layout open all the time, at least while they are routing.

1 Like

OT, reminded me of the old joke:

Pundit: All (American) Indians walk single file. At least the one I saw did. :rofl:

Actually I only sometimes work with both windows open but it would be because one was left open, as I have only one screen, so I flip between windows or virtual desktops.

I was using Protel 3 since 1997 til 2017 and there (as I know) were no communication between sch and pcb other then by netlist. When I moved to KiCad V4 at the beginning I just didn’t know that if I see both windows they cooperate with each other. I learned that may be in 2018.
But after having elements divided into groups (supply, microcontroller with its capacitors and quartz, ethernet interface, RS485 interface, relay outputs, digital inputs) I just don’t need schematic.May be if I had two monitors I would open schematic but at one (24") there is too smal space left for pcb if I open schematic also.
At pcb I switch off reference numbers and values as I had problems that sometimes instead of taking by mouse part I took its reference or value (I have references and values at center of footprints). I just work with it like with puzzle don’t being interested what is the name and value of anyone of them. Of course I have schematic in my mind but without references.
If the schematic would be made by someone else than probably it would be harder to have it in mind, but I work only with made by me schematics. I’m sure that having schematic open will help me very, very little if at all. Because of this I supposed other work similarly, but being not sure I have added ‘may be’.

I always use the schematic and PCB on multiple monitors. The highlighting of symbols/components on both monitors is a awesome feature.

2 Likes

I agree about dangerous shortcuts but they are so useful. I find the ability to use KiCad with two monitors showing schematic and PCB to be one of it’s nicest features (especially Ctrl-D or Cmd-D on the Mac when placing symbols) and two handed operation with mouse and keyboard just makes things so much easier but I have to be really careful with the shortcuts. I use Ctrl-Z a lot but if I lose track of which window is the focus it is easy to suddenly undo a whole lot of work on the wrong screen.

1 Like

note that v7 will include an option to change the focused window based on the mouse location: Option to switch focus between SCH and PCB windows on hover when the focus is on the other window. (!1326) · Merge requests · KiCad / KiCad Source Code / kicad · GitLab thanks to dsa-t

3 Likes

I’ve long thought there should be a **LOCK** button on both the schematic and layouts. This is one reason, another reason to have that would be just opening up the design to check or look at something and not wanting the possibility of accidentally making any changes.

2 Likes

I mean for layouts this function is there for quite some time now. But good point that it also would be a nice to have for the schematic.

I think the Lock feature you’re referring to is for individual items (or groups). I use it for holes and other critical components that need to be in a particular place or orientation. I’m referring to and asking for something similar, but as a whole “design lock” such that it won’t be possible to change it with out purposefully “un-locking” it.

2 Likes

If I understand you right, you are speaking of Locking the Schematic, right?

I think this would be a great option, maybe a toggle in Schematic to switch to ‘Read-Only’ so as you are doing layout, you cannot accidentally edit the Schematic.


(Until this feature gets added)

After reading…

…I did some digging. If you are using Win10, this is the fix (I just tried it on v6.0.9 and I am going to love this)
“Activate a window by hovering over it with the mouse” is selected in the accessibility settings. This option can be found under Control Panel > Ease of Access > Change How Your Mouse Works .