Is there LTspice for Linux?

Is there LTspice for Linux? the last time he studied was through a wine crutch…

Best I know, there is not.

The reason I split it off though, is that I want to keep that other thread clean. Holger is very knowledgeable about all ngSpice related things (I believe he even is the maintainer of the whole ngSpice project). and from what I understand, I don’t see him much on topics not ngSpice related, and I don’t want to waste his time on derailing threads.

1 Like

There is an LTspice for Ubuntu in Github… and perhaps other’s Google it

1 Like

tonda can write private messages?

GitHub - joaocarvalhoopen/LTSpice_on_Linux_Ubuntu__How_to_install_and_use: Make great analog designs ?

Yes, if you want to have some private conversation with me, just click on any place you see my avatar, and then click on the Message button.

I know I ran it on Linux in the past. Way past. Probably WINE?

And, there is PlayOnLinux (I use PlayOnMac to run some Windows App’s). It’s free.

There’s also Codeweaver’s ($) - another Wine utilization…

in any case, there is no direct support for Linux, everything through a crutch? did I understand correctly?

I’ve been running various flavors of LTspice on Linux via Wine for many years. It works very well and I’ve never noticed any problems.

There’s a fair bit of discussion of Linux topics on the Analog ADI EngineerZone forum for LTspice. Analog is somewhat responsive to questions, and is unofficially supportive of running it on Linux via Wine.

My last communication with wine caused a breakdown of root access rights in Ubuntu and other bad things) so I’m careful about applications that work through a crutch … As practice has shown, there is nothing more stable than a virtual machine, but like everyone else, I wanted direct support

I’m baffled at the slow ports to Linux given the growth of Android. I guess it is still the ‘installed base’ thing? Who knows.

I am not sure about the details, but I think I once read that the makers / maintainers of LTSpice put some effort in it to make sure it plays nicely with Wine.

With wine, it probably works well, but Vine itself with Linux is not very good. It’s one thing to play toys and another thing the system for work falls)

According to a reply in the LTspice support forum, the code is heavily dependent on the Microsoft Foundation Classes and porting to Linux isn’t seen as feasible.

The interesting thing is there is now a version for Macintosh. I’m not sure how that figures into things.

Wine works fine, LTSpice in particular is basically using the ancient relic win32 MFC controls and doesn’t even use opengl.

Last time I tried to install WINE on Debain 11 it failed miserably for some reason. So, just tried on a fairly clean install of Debian 12.

Installs with recommends but complains about no 32 bit support when tried to run. Sounds familiar. So, run recommended dpkg command. Try again.

hermit@~:wine ltspice
0024:err:module:import_dll Library kernelbase.dll (which is needed by L"C:\windows\syswow64\kernel32.dll") not found
wine: could not load kernel32.dll, status c0000135

This is as far as I care to take this. They seem to have a Mac version which is now Unix based, but no Linux version. Oh well. I wasn’t gonna use it regardless. But, point is, WINE isn’t installing and running properly on Debian 12. Didn’t on 11 for me either.

yes, I was talking about this eternal dance with a bun, or it works every other time or it doesn’t work at all … my vine generally hung up the system after root access … today the most reliable option is a virtual machine … on the other hand, the software is very little under Linux in all areas of design …

LTSpice works fine for me on a CentOS 8 system with locally built WINE-8.15 (built as a set of RPMS for ease of upgrade and installation).

Fedora provides 32 bit support in package wine-8.14-1.fc38.i686.rpm.

I am no expert on Debian systems, but 32 bit support for “bookworm” appears to be provided by the package wine32_8.0~repack-4_i386.deb.


I have no idea about the mechanics of installing it or configuring it (if that is required).

Point is, package installer installed WINE with the recommended packages. It recommended more when I tried to run it… Installed more. Still didn’t work. I gave up on this in Debian 11.

I have an old laptop with Windows 8. Microsoft’s parting gift to me was to break the video drivers in the last supported update. So at that time, I tried to install WINE to see if it would run the tax software. I ended up using an inherited laptop with Windows 10.

I’ve used some form of Linux since Redhat 5.2, sometime around 1995. I know only because Windows 95 hit around the same time and that was my first Linux distro. . I just happened to see it in a store my brother took me to in Milwaukee. I still have the boxed set. Of course I still have my OS2 Warp CD’s too. Hey, if it was good enough for the nuns… Not sure how many people will get that reference. (US TV commercial)