Installation does not work properly: Strange Graphics

Hello All,

I selected category Schematic but actually it is General, but also schematic does not work.

After many years using Altium Designer I decided to try KiCAD because the most basic functions of AD are still not working properly while they add more and more making it far too complex to ever get bugs under control.

But after installing KiCAD, it is not working, I cannot even start with the First Use schematic.
Opening this schematic, I see very strange graphics, completely unrecognizable.

I tried to enable the graphics accelerator, no difference (cannot find anymore where to disable it).
Below is a PrintScreen, I hope it works.
It is the First Use schematic Framed Size.
The same strange graphics is seen for a PCB file.

If I doubleClick on this schematic file in the file browser it opens in Altium Designer correctly.

What KiCad version did you install?
Go to: Help / About KiCad / Copy Version Info and then post it here.

Where did you get your KiCad version from?
I would not trust any other source then:
Apparently the Windoze version also does verification of it’s own integrity. Were there any warnings or errors during installing?

Can you post a screenshot of a more zoomed out area, that may give a better idea of the error you are encountering. Maybe someone recognizes it.

In this old thread:

There is a simple KiCad design. You can download it and then compare with the screenshots posted there.
You also have easy access to a whole lot of example projects via:

Do those example projects also look corrupted?

Graphics acelleration settings is in:
** … / Preferences / Modern Toolset (Acellerated) [F11]** and in:
** … / Preferences / Modern Toolset (Fallback) [F12]**

Posting a screenshot of Pcbnew may also help to get a better idea of what is going wrong.

New users have a limited upload capability as anti-spam measure.
@moderators Can you bump this user so he can upload more screenshots?

Is this a schematic from Altium?

Thanks Paul, also for the links to more info for starters.
I used one of the links on the page you mention, I think CERN.
Version info:
Application: KiCad
Version: (5.1.7)-1, release build
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.71.0
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
I use Win7 (build 7601, SP1) 64-bit Pro.

This is a screendump with maximum zoom out.

What is the origin of this?
Is it a design imported from altium to KiCad?
If so, start with working with KiCad alone. I’m not sure that the Altium importer is stable and ready for use yet. (I also have not kept a close eye on that part).

Also, KiCad’s current version is 5.1.8 (while you have V5.1.7) but apparently only Windows 8 or newer is supported:

I use Linux myself, so can not help much with Windows.

It is the FirstUse schematic that comes with the KiCAD installation.
When I open the schematic in Altium, it seems OK.

I don’t find such file from KiCad. Please attach the file here or at least give the file path in your KiCad installation. D:\KiCad\FirstUse can hardly be the original path if it has come with KiCad.

Please forget anything to do with Altium for a moment.

  • Nothing of Altium itself.
  • No imported projects from Altum.
  • No exports from KiCad to Altium.

Just start KiCad, then in the project manager:
File / New / Project (Add a name + [Enter])
Then Open Eeschema and add some components from Eeschema’s libraries.

Does Eeschema work?
Do you say the page layout with title block?

I installed KiCad some time ago and left it when I could not see the first schematic.
Possibly the file was made by making a New Schematic.
It’s attached here.
Test.sch (72 Bytes)

I did nothing with Altium when installing and trying to add a schematic.
Only double clicking the new schematic file in explorer resulted in my PC opening and showing it properly in Altium as shown above .To my surprise, because Altium schematics have extension *.SchDoc.

Eeschema opened properly (all buttons and window present) but does not show schematic.

I never used Altium myself.
I heard some complaints about Altium that it thinks it’s king and changes lots of file associations to link to itself. Even C source code files and configuration files for other IDE’s.

How did you make that Test.sch file?
A size of 72 bytes is suspiciously small.
It’s contents are:

EESchema Schematic File Version 2

If I then open it with Eeschema V5.1.8 it opens as a normal empthe sheet, and if I then save it, it grows to 208 bytes and it’s contents are:

EESchema Schematic File Version 4
$Descr A4 11693 8268
encoding utf-8
Sheet 1 1
Title ""
Date ""
Rev ""
Comp ""
Comment1 ""
Comment2 ""
Comment3 ""
Comment4 ""

That first file must be from a very old Kicad if the file version changes from 2 to 4. (V5.99, soon to become V6 has a completely different file format based on S-expressions just as Pcbnew)

Double clicking on a schematic file is also not a good way to work with KiCad, as it opens Eeschema (if altium does not interfere) in “standalone” mode, and this is not fit for working with a KiCad project.

When working with KiCad, you should always start with the KiCad project manager, which looks like:

And then, in the project manager, create a project with:
File / New Project, and then start Eeschema, Pcbnew and other sub programs by clicking on their icons.
More about KiCad projects in:

To give it a kick-start (looking at examples provided by the KiCad installation):

I have just installed KiCad 5.18 from using the 64 bit version, OS is Windows 10. My installation directory is C:\Program Files\KiCad\ .

The installation creates a KiCad icon on the desktop.

Double click onto the icon to open KiCad.
File-> Open Project ->C:\Program Files\KiCad\share\kicad\demos\ecc83
(There are many other demos available, my selection is for nostalgic people).
In KiCad click onto the ‘Schematic Layout Editor’ icon.

And voila, there is the circuit schematic visible.

Click onto the ‘PCB Layout Editor’ icon, and you will see the PCB.

I am not yet in the stage to run tutorials because the schematics and pcb’s do not show, only some strange forms as above.
The same is the case when I try to add a schematic component.
The component browser has a small window that probably should show the part you browse.
It does not, some strange lines are displayed in that window, different patterns for different parts.

The KiCad program itself shows OK, all buttons and menus are there as expected.
Probably my video card is incompatible with the way schematics and PCB files are sent to it.
I use ATI Radeon HD 6800 with driver 8.801.0
Tried to update drivers but it says the best driver is already installed.

OK, the file isn’t the problem. It’s in graphics rendering. Especially the gray blocks looks suspiciously like some graphics card driver issue. You didn’t answer paulvdh’s “question”:

Try those settings.

Sorry I did not notice these settings.
Pressing F12 results in the correct view of schematic, PCB and Parts browser.
I can now start the evaluation.

Thanks for the help!

Glad you got it working but just FYI, windows 7 is no longer supported by either Microsoft or Kicad. It’s no wonder issues start creeping up in an unmaintained system.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.