Input focus on Mac OS X lost in dialog boxes


#1

Hi all,

I’m trying out one of the nightly builds, and I find that the input dialog boxes in schematic will sometimes loose focus. This happens when the operation is complex, clicking around various fields, maybe switching to another application…

Here is what that looks like:

Notice that the dialog box -does not- have focus, the window behind it does. Input doesn’t seem to go anywhere: hotkeys don’t work, tab doesn’t change fields, ^W doesn’t close the window, ^Q doesn’t quit, clicking any of the window close buttons doesn’t…

The application is -not- frozen, however. The OS doesn’t report it as such, but sending it Quit from the task bar also doesn’t cause it to exit. It has to be killed, even though it is not shown as “stopped responding”.

I suspect it’s simply that the input focus has become… unfocused.

Thanks for making the nightly builds available for testing.

Update: This happens reliably when eeschema is run from the kicad top-level ‘shell’ program. The way to reproduce it is:

  • Try to a Git repos to the library list.
  • Click through the dialog boxes
  • Allow it to download (doesn’t matter where)
  • The list will scrollbox not update. The dialog box hangs.

Now you have to kill the kicad program.

Work around: Run eeschema alone, that is not from the kicad program. I suspect other hangs I’ve experienced also are caused by the same bug(s). More evidence that this is confusing the Mac window system is kicad is the name of the program in the title bar, not eeschema. No useable menu items are available when this hang occurs.

Nightly Dec 28. Mac OS X 10.13.2.


Can't edit another component after changing component value
#2

These child windows prove problematic in other ways. Some will freeze the everything until you close it and if you accidentally hit ‘minimize’ instead of ‘close’ you can be screwed because there is no way to get it back. At least that happened once under Debian Stable. I wasn’t sure if it was the program or the window manager to blame though. I had to kill the program from the command line.


#3

Activating the main window of kicad should bring the open dialog back up front.

Depending on window manager there is another option. Most of them have a mode that allows the user to view all available windows. Even minimized once. For cinnamon it is with shortcut crtl+alt+arrow down.


#4

No, activating the top level window doesn’t help (on Mac OS X). In fact, you can’t, because input is going somewhere else.


#5

Usually under KDE if I press the ICON in the lower task bar it will show all open windows for a particular program. It didn’t that one time for the minimized child. I’ve just been careful to avoid that situation again so I don’t know if it will repeat.


#6

Just a heads up: this is a user forum. Bugs should be reported over at the bugtracker:
https://launchpad.net/kicad/+bugs

(We can only try to give workarounds.)


#7

Also monitor the GitHub


I see a lot of OS X work to overcome window management features

The developers need more OS X users running recent Nightly to fix these issues. Most of us on this forum on Windows and Linux.