Inner layers not visible in 3D Viewer


#1

In 3D Viewer I am only seeing the copper on the outer layers of an 8 layer board. I have ‘show board body’ turned off so I can see inside the board, but there is nothing there except the vias. How do I control which copper layers are visible in 3D Viewer? KiCad version 4.0.7.


#2

You need to deactivate the “Realistic mode” on Preferences of 3D Viewer.


#3

Looking at the 3d view in this way isn’t really a good alternative to reviewing the Gerbers. As well as numerous 2d viewers, there are some 3d gerber viewers available which you might find helpful if you like to see a multilayer representation of your board - especially if you want to check continuity of specific traces with a ‘fly through’ mode.

Screenshot from zofzpcb 21


#4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.