In Kicad Version 6 not able to use the plugin

In kicad version 6 can you please explain how can i add the plugins?

In scripting folder-plugin i have paste the plugin.
And in kicad pcb editor in tools menus refresh plugin i have tried but plugin is not coming

Which plugin you are trying to use?
What is your OS?
Where exactly did you try to put the plugin?

I have used the tear drop plugin, bga fan out plugin.
We are using ubuntu
path of plugin:-computer/usr/share/kicad/scripting/plugin

Plugins written for kicad v5 rarely work with v6 without changes. You need to make sure the plugin you are using specifically supports v6. Without a link to the plugin I can’t tell you if it does.

Don’t put plugins in /usr/share, go to Tools->External Plugins->Open Plugin Directory (new feature in v6) and put your plugins there.

yes we also did the same but it is not working.
I am also also attaching the screen shoot of my path.

Path is correct, most likely the plugin doesn’t support v6.

Can you post screenshot of Preferences->Action plugins panel?

I have attached the screen shoot of Preferences->Action plugins panel.

If you press on the little yellow warning sign it will show why some plugins failed to load. Copy paste that text here.

1 Like

I Am now able to see plugin but i am seeing the error when i am clicking on that plugin.error

Yep, that’s because the plugin was not adapted for v6. Modules have been renamed to Footprints in the last version among other changes.

Do you know what changes should i made to .py file to solve this error.

GetModules() should be replaced with GetFootprints() for starters but beyond that how many other errors you will get, who knows.

If you want to fix it either share the script and maybe someone here will spend their time on it if they are interested or learn some python and study the kicad api docs.

I am not able to attached the plugin file because i am new user so it does not allow me to attached the file.
Plugin file

Please send me this plugin file which support in KICAD version 6.

currently i am facing this errorsERROR1
Help me to Reslove.

Where did you download this plugin?
Very few plugins have been ported to v6. I know of one working dogbone plugin and it is in a temporary repository to “get things working”

Check the plugin repository to see in the master has been worked on within the last month, whether there is a 5.99 or 6 branch, if there are any active issues on compatibility

I have checked the plugin repository and i am not able to find version 6 plugins so please help me.

Then the plugin isn’t compatible with V6. Please talk to the plugin author

If you mean the script from Laksen:

it hasn’t seen any updates for 5 years, so I’m guessing it is not compatible with the soon to be v6

Maybe the following fork is useful? The last commit is from this year (“update to partially work with kicad 5.99 nightly”). Good luck

no it is also not working.

IT is asking me number of layers to skip.
I have enter 0.

After this it is asking me to number of layers quadrants
I have enter 2.

after that it is showing me the error which i have upload the screen error_for_bga shoot