How to update symbol in schematic?


#1

I created a schematic symbol and placed it into my schematic.
Later I changed that symbol.
How do I update the schematic so that the symbol matches the new library part?


#2

Happens for me instantaneous?!

Can’t test it now as I just installed the latest nightly and they seem to have changed the library setup…


#3

It only happens instantaneous if you start the symbol editor from within eeschem.
(By right-clicking it and selecting “edit component”->“edit with library editor”. Or short [Ctrl+E])

If you start the library editor from the project manager and edit your symbol from there you need to close eeschem and reopen it to be prompted with the rescue symbols dialog.
There you need to select don’t rescue.

Another possible failure would be that you forgot to save the library changes to disk (in the symbol editor it is the leftmost button).


#4

Neither closing and reopening the schematic editor did anything nor right clicking on the component “edit component”->“edit with library editor” did anything. In the latter case I tweaked the component slightly and saved it.

If I place a new component, that component is updated.

I forgot to move the reference designator back. (i know that at this stage i could just delete all the symbols and place new one, i just want to know for the future where this might be too difficult to do.)

Here is an image of the older symbol vs the new symbol.


#5

Just for fun (and to get a better understanding of what is going on) try to make a more major change to the symbol.
I observed that footprints can’t be updated (not even with the tool update footprint) if you only change the 3dshapes settings.
Maybe something similar is going on with symbols. (I think the position of the reference designator is initialized upon placing the component, but then it is not updated from the symbol. Otherwise you would not be able to move the reference.)


#6

Yes, the position of the refdes is overridden in the schematic. You can reset the label positions by going to Edit Component then click “Reset to Library Defaults”.


#7

You must have a case of ‘same component in different libraries’ or similar… only the one that appears first is being taken and updated, not the other ones.

For the component that behaves odd try this:

And select the component that properly updates (essentially replace it). Should solve your problem.


#8

Is there anyway to do this for every similar part on the sheet?

I think I’ve made a mess of one of my symbol parts.


#9

Maybe by ‘tricking’ the rescue symbols function at the start of EEschema to become active?

I think you would need to change the symbol in the lib and then reload the schematic, it should ask you if the ones in your schematic should be rescued or if you want to use the one from the lib… I hope

  • fingers crossed *

#10

I was not able to figure it out. I gave up and just changed 20+ manually.

It seems to me now, that the mistake I made was not updating the time stamp of the part that I wanted to use. But, I’m not certain.

There are a couple of other symbols that I want to change so maybe I’ll get it figure out sometime in the future.


#11

Did anyone work this out?
It seems the only way to update the component on the schematic is delete and add new.
Not very convenient.


#12

I just tried a redraw after another component edit and this time it worked!
Maybe you just need a little luck.


#13

I would like to take up this topic again.
Firstly say that in the latest version, many good changes have been made and I want to thank all the developers.
I’m now using version 5.1.0-1 and also the nightly versions.
So I would like to know if the rule for version 5.1.0 has the same operation as clarified by Rene_Poschl, as shown above.

If so, I believe there must be something wrong because it is not working as described by Rene_Poschl. Every time I want to make a change in a symbol, the update does not happen immediately (starting the symbol editor from within eeschem) or after loading the lib again (starting the library editor from the project manager).
The only way I have found to update a symbol is to delete and add again. Which I understand is very inconvenient.

Last week, in some cases I was able to update immediately (starting the symbol editor from within eeschem), but this week it does not work. I am using for this test only the version 5.1.0-1. I am not using for this test the nightly version.
I honestly do not know how to explain, how in some cases the immediate update worked.
It seems to me that there is some instability even in version 5.1.0-1.
In nightly versions does not work!
Is this possible? Is anyone else facing this problem?


#14

This may be related to aliases in the Symbol editor; an issue that I myself do not fully understand.


#15

I’m also very confused because sometimes last week as I commented on this topic, it came to work.
To test your suggestion, I create a new project, a new library with the symbol L5973D following the following steps:

The update did not occur.

In summary, Kicad did not update the symbol in Eeschema.
The only way to update the symbol was to delete and add again.


#16

There is a bit of a difference here. Above i wrote about symbol updates that change the symbol itself (The graphical part of it). These are propagated to eeschema when using the described workflow.

Changing fields does not trigger this at all. (This was already this way with version 4.)

The way to get fields updated is by opening the symbol properties dialog (right click -> properties -> edit properties or hotkey “e”)
In this dialog there is a button called “update fields from library” which lets you then decide which fields to load from the lib.)


#17

Understood.
In this case I did this and still did not load the field created .

I reloaded the eeschema again and continue without adding the desired field.


#18

Correcting …
Once you have done this, you need to Edit again and select to show the field …
Now it worked.


#19

Or select “reset field visibility” in the reset fields dialog.

You are however right that it is strange that the list of fields is not updated when this dialog is done. I will report this as a bug.


#20

ok Thanks!

Maybe it would be interesting, for it not to be somewhat strange, that the settings made in the Symbol editor are replicated in Eeschema even if you have to do the following steps: Properties -> Edit Properties -> “Update From Library …” .

I understand that it is appropriate to “authorize” the upgrade, but it should be what has already been done in Symbol Editor. It seems to me, that is more practical for the developer.