How to remove footprint text from schematic

I have moved from Kicad 5 to Kicad 7 and now I see text for every footprint all over the schematic which I cannot get rid of.
This text is selected from properties->footprint->value.
I simply want to remove it from the schematic everywhere for every symbol yet I cannot see where to do this.

Can someone advise? Thanks in advance Rob

Hover mouse over text and press Delete.
Text will be removed from schematic but remain in Symbol Properties as unticked in the Show column.

If you delete the wrong text, use the Undo last Edit tool and try again. :slightly_smiling_face:

Thanks but did not work ! Using Kicad 7.0.9 (latest).

VEEEEERY ANNOYING !!!

The footprint text is showing in a purplish color?

It is in a light blue colour on the schematic. Can’t get rid of it , tried everything !

For all of the symbols. :frowning:

Please read this article in the FAQ: New Member Information and follow the advice until you have promoted yourself to “basic user” level.

You are then allowed to attach your project (Kicad main manager → File → archive project), so we can look into it. Also maybe a picture could help.

How is your setting in View–>Show Hiden Fields?

1 Like

Ah, your memory is better than mine. I was still trying to remember where I’d see light blue. :grimacing:

Thats was it yes! Thanks
much appreciated
Regards
Rob

I also had this same issue after upgrading from version 6.0.9 to version 7.0.9, and suddenly those ugly light bluish labels popped up everywhere, and I couldn’t get rid of them.
It seems in the View, the Show hidden pins was checked(I didn’t do that. It happened by itself when I opened the schematics in the new version 7.0.9). Thank you. This problem is resolved now.