How to remove 3D model but keep pads?

I want to remove the 3D model of a 2x20 Horizonal Pin Header and leave only the hole pads. I’ve found this thread: Can I disable the 3d model but keep the footprint per instance? but I have no idea how to any of those solutions.

I can’t find how to set a footprint to be virtual.

When I press E on the connector I get to see ${KISYS3DMOD}/Connector_PinHeader_2.54mm.3dshapes/PinHeader_2x20_P2.54mm_Horizontal.wrl but if I un-tick the preview box, it still shows when I press ALT+3.

First of all: do I need to remove the 3D model for the Gerber files ? All I need is a PCB with holes and traces.

The 3D models are purely used for visuals when using the in-built 3D viewer or for mechanical constraints when exporting as STEP.

They do not appear in the GERBERS/Plots/Drill as such information is not required for the fabrication of a PCB

1 Like

Thank you for the prompt answer.

What is your reason for wanting to disable the 3D model for (only ?) that connector?

The preview checkbox is only for the preview window, not for the 3D view of the whole PCB.
One way it can be done is to change the link to the filename to something non-existent.

or to put the X, Y, Z scales to 0. This is the way I proceed to mask a 3-D model from a multi-model footprint. But I suspect that all the models are loaded increasing the file size and processing time.

As far as understood, no solution is needed for the original question because the 3D models don’t affect the manufacturing files. But if anyone’s interested…

This is quick and dirty for the KiCad’s internal 3D view but not a correct solution if someone needs to for example export STEP. Adding some character to the file name to make it non-existent, as hinted to by paulvdh, is better.

The proper solution will come in v6: the Preview choice of the model in the footprint Properties have been changed to real Show property which effects not only the KiCad’s 3D viewer but also 3D export. Probably the model should be enabled in the library file by default and should be turned off case by case basis after it has been placed to the board. It’s also possible to keep the property when updating the footprint from the library.

1 Like

If you do find a reason to remove the 3D model, just create a local copy of the footprint in a private library and delete the 3D model associated