Can I disable the 3d model but keep the footprint per instance?


#1

I’ve got connector holes on my PCB for which I’m using a pin header footprint. But I intend to solder wires to the holes. On the 3D view it shows the pin header installed.I know I’m not obliged to install a pin header but I would like the 3D view to be realistic. So can I:

  1. Disassociate the 3D model just for that instance of the symbol, or
  2. Use another symbol with the right number of pads and spacing (2.54mm)

I know it’s just cosmetic, but I’m fussy. :smile: If it involves a custom footprint I’ll just live with it.


#2

Cleanest option: copy the footprint into your local library and remove the 3d model from it.

Dirty but fast: edit the 3d model settings of the placed footprint (press e while your mouse is on top of it to get to the preferences dialog that allows to do this.)


#3

Thanks, the latter was just what I wanted.


#4

Another option (intended for just such use case) is to mark component as virtual in footprint properties. Then in 3d viewer virtual component models are disabled by default (there is an option to show them).


#5

I think I tried that in the process of working out how to implement Rene’s second suggestion but the pads also disappeared. Only by deleting the path to the 3D model did I get what I wanted.


#6

That’s weird, I just tried on nightly build, pads don’t disappear. I’ll try on 5.1 in a bit.