How to pan in schematic editor and pcbnew when you don't have a mouse?


#1

Hi. I am very new to KiCad and am trying to migrate from Eagle. I have a gazillion questions, but here is a very basic one. I can’t pan around a schematic or board. I haven’t used a mouse in about a decade. I use a Mac with a wireless trackpad or a Wacom tablet. There is no equivalent to a “centre button on a mouse” that I can see. Help?


#2

How do you pan in Eagle?


#3

In Eagle you just hold the pen on the Wacom tablet and ‘drag’ to pan. Doing group edits requires an easy selection of a group selection tool just like many other programmes.

I just discovered Use Touchpad to Pan. It’s a bit of a pain as I have use fingers rather than pen, and have to toggle touch on and off on the Wacom, but at least it works. But I am surprised there’s no pan tool or hotkey activation of panning with mouse/pen?


#4

Why are you surprised?


#5

Might not be a lot of people who use KiCAD that way.
Wacoms I’ve seen in use with the Photoshop crowd who do stills or textures (essentially 2D artists) and 3D sculpters (Zbrush comes to mind).

Asking the other way around… how’s Wacoms scripting/macro ability/support?
Can you program features for the tablet that would ‘simulate’ mouse-actions on the computer?


#6

KiCad loves hot keys. “With KiCad your left hand will be on the keyboard” (one could add “like never before”). Why undo the natural action of click and hold to move content i.e. pan? Better to have a hot key change this function to group selection or at least a setting to control this behaviour. For example: Hot key P = pan or Preferences: left click and hold = 1) pan or 2) group selection; the latter requires a hot key for group selection so perhaps a simple hot key for pan would be better. I’ve gone from using one input device to now three at once. I could not see a hotkey assignable for panning.

Re Wacom, it’s very powerful but I haven’t managed to find a way of overriding the behaviour in KiCad yet. There is a way to “middle click” from the pen configuration but ‘middle-clicking’ with the pen and moving the pen doesn’t seem to work/pan with KiCad. KiCad doesn’t support “application defined” Wacom behaviour so that avenue is a no-go. Once you start drawing - any form of drawing not just PS-type brush/sketch - with a Wacom or similar tablet you will find it very difficult to use a mouse again.


#7

Hm… workflow wise I zoom out, move the cursor over the area I want to be next and zoom in again. I guess most people will do it like that after a while and don’t really miss a pan-function.
With more people coming aboard this train there will be customizable hotkeys at some point - just don’t hold your breath (or hope for a gifted former Eagle user that wants such a feature and puts it into code) :slight_smile:

Hm… can you program a wacom pen click 1 (=middle mouse button pressed), move pen, wacom pen click 2 (=middle mouse button released)?
Did you try something like that?
Somewhat like the change between 2 trigger / 4 trigger setup on a TIG torch.

Thanks for the heads-up :wink:


#8

If your next point of interest is just out of view, why zoom out and then back in again? Especially if the point of zoom isn’t in the right spot.

I can define in Wacom settings for one of the pen controls ** to be “middle click”. However, using “middle click” (holding the defined button down and moving the cursor) is not working in KiCad. I presume KiCad doesn’t recognise this middle click, as presumably other programmes do else Wacom’s implementation of middle-click would be woefully lacking (not that this isn’t a possibility). If it did it would be easy-peasy. I’m not sure why it doesn’t work.

** the pen has a point for clicking and a toggle where the index finger rests on the pen which can (by pushing forward or backwards) alter the nature of the click. (As well as eraser end which can be defined also.)

“Difficult” in the sense of “highly tedious”.

Anyway, I will soldier on.


#9

Huh, I realise I hardly ever pan in Kicad, I used “zoom out/in” method. That has always worked because the redisplay is super-fast. Otherwise I just use the scroll bars. Pretty easy.

Personally I would like every application to support my 3D nav mouse, once you’ve used one you’ll never want to use anything else.


#10

FWIW KiCad doesn’t recognise a simple right-click from a Wacom pen either. This is the first software program where I have encountered these problems.


#11

Yeah, it took me a while to learn that technique but it IS quite practical because the redisplay IS super-fast. However, recent nightly builds don’t seem to implement the “zoom out/in” function the way it worked a few weeks ago. Rather than centering the zoom around the mouse cursor, the zoom in/out always seems to center around some fixed point in the lower left quadrant of the worksheet. The problem goes back to at least the 4790 build of 15 January.

Dale


#12

Can’t confirm for this nightly (zooms in/out in both legacy and opengl around mouse pointer):

Application: kicad
Version: (2017-01-20 revision 550a1ea)-makepkg, release build
Libraries: wxWidgets 3.0.2
           libcurl/7.51.0 OpenSSL/1.0.2j zlib/1.2.8 libssh2/1.8.0 nghttp2/1.16.1 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
- Build Info -
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.62.0
Curl: 7.51.0
KiCad - Compiler: GCC 6.3.0 with C++ ABI 1010
        Settings: USE_WX_GRAPHICS_CONTEXT=OFF
                  USE_WX_OVERLAY=OFF
                  KICAD_SCRIPTING=ON
                  KICAD_SCRIPTING_MODULES=ON
                  KICAD_SCRIPTING_WXPYTHON=ON
                  BUILD_GITHUB_PLUGIN=ON
                  KICAD_USE_SCH_IO_MANAGER=OFF
                  KICAD_USE_OCE=ON

#13

Build 7601 here on Win7 64 bit and mouse wheel zoom in/out works centered on the cursor on both schematic and pcbnew as expected


#14

You are correct: The mouse wheel zoom works correctly, like it has since I started using KiCAD nearly 2 years ago.

Zooming from the hot keys < Alt-F1 > and < Alt-F2 > does NOT zoom around the center point I expected. (This is in the nightly Windows builds, going back at least 10 days and continuing through the latest kicad-r7525.8f82f04-x86_64.exe. )

Investigating this zoom behavior today, I noticed that after zooming with the mouse wheel, subsequent zooms with the hotkeys will center on the location last used for a mouse-wheel zoom.

I had trained myself to use hotkey shortcuts but will alter those habits to use the mouse wheel.

Dale


#15

I can confirm this. Using Alt-F1 and Alt-F2 only works as expected AFTER using the mousewheel. Even clicking the mouse is not enough to update the zoom point

Time for a bug report


#16

https://bugs.launchpad.net/kicad/+bug/1659731

Dale


#17

Here’s a cheesy work-around: hold down F4 (Zoom Center shortcut) while moving the mouse cursor around. Done! The zoom-out/zoom-in thing is also ok, but I really prefer panning over that.

Source for where I found out about the F4 thing: https://www.eevblog.com/forum/kicad/one-annoyance-of-kicad-solved-f4-drag/


#18

@Gabriel_Staples Interesting first post; digging up a thread over a year old.

Welcome to the forum.