How to make a clean reinstall of Version 5.1.2


#1

Help Needed: How to reinstall Version 5.1.2, to fix performance issues.

Quick summary of problem : Version 5.1.2 was working great, then had serious problems. Reinstalled it, without uninstalling first, DID NOT FIX PROBLEM S . Then, UNINSTALLED it FIRST, then reinstalled, DID NOT FIX PROBLEMS. How do I do a clean reinstall of 5.1.2 to fix problems, or fix problems another way?

Installed on Windows 10-64, used Windows “Add or Remove Programs” app to uninstall

Likely cause of problem : I had 16 programs, etc, open when using KiCad. Might have run out of “resources.” (Amateur’s guess)

How problem developed : I was looking at the 3D Viewer, and it was working perfectly. But, as I rotated the PCB, suddenly, the image changed. The green PCB changed to a dark color. The image became blurred, and the entire screen had to refill, in small rectangular blocks, taking about 10 seconds. Refilling starts in lower left corner, and finishes in upper right corner. Then the image becomes clear again.

Serious other problems soon followed, and KiCad became unusable. Then I tried the reinstalls.

Quick History:

Upgraded from 4.0.7 to 5.1.2 a couple of months ago. Windows 64 installation.

Started over with libraries and schematics, allowing a “clean” install.

WORKED GREAT! Designed 2 boards.

Current Status:

1) 3D viewer still screwed up, the same as before.

  1. Printing Gerber layers, using “Fit to page,” the prints come out various sizes. Sometimes full screen, other times roughly 1:1.

  2. ??? I’m sure there are more problems to be discovered.

PLESE HELP:

Just finishing 1st PCB for a new client, must design another ASAP (had planned to start this weekend).

KiCad must be trustworthy before starting new board.

Thanks for any help!!!

P.S. Couple of details :

First reinstall, used original 5-15-19 download (1,171,336 KB), and the 2nd reinstall, used a new download 7-4-19 (1,171,365 KB). Same bad results both times.


#2

Did you by any chance choose ‘raytracing’? It will slow my system down quite a bit.


#3

#4

In that case, installing a third time is unlikely to help. If you have 3D problems, it could be video driver issues, often difficult to diagnose.

If you need an urgent job doing, stick with 4.0.7. Try to resolve problems with 5.1.2 later. FWIW, I’m still using 5.0.0.


#5

Hi All,
I have been searching the web for solutions. I am now using Version 5.1.2)-2 release build of Kicad. Starting off with version 5.0.
Things worked well until my Video card Burt out (Manufacture fault with 3 week old Nvidia GX1060
The new card is now in and running, however Version 5 stopped allowing the 3d view - Window opens with icons. Page is white and then I get the (Not responding) error in the title bar.
This of course crashes KiCad itself.

I now have the situation a project I was working on has a corrupted .sch file, that now causes the schematic editor to also crash (Not responding) error, and Kicad closes.

Creating a new project and the same result - Tried un-installing, and re-installing, downgrading to 4.0 of course that will not open the .pro file at all. Oh and the 3d viewer crashes out Kicad as well (4.x). So rolled forward to current version. Cannot open a major project I have been working on. Cannot open the .SCH file. I can open the PCB file, but cannot view 3d.
What Gives.

This is Windows 10 x64 with up to date windows patches and the latest NVIDIA driver install. Everything is installed to my D:\PROGRAMS DIR as I do not use the SSD for programs.
Although I did test by installing on the SSD. But same results.

I am not a programmer, or a rocket scientist when it comes to the file workings of Kicad.

Any help on maybe how to fully remove it and a sterile install if that would help? or any other fixes I can Try. (And is there a file repair tool out there? )

Mat


#6

I’ve found KiCad to be quite trustworthy; however I have very little good to say about Windoze, of any version.


#7

You have the option of sharing the file with the members of this forum; you might get lucky and someone may have a solution.


#8

@sprig He is not using nightlies. 5.1.2-1 and -2 are stable releases.


#9

@bobc Certainly appears to me to be using nightlies.

Windows Stable Downloads

2019-04-24T22:44:26.081Z 1.1 GB kicad-5.1.2_1-i686.exe
2019-04-24T22:46:22.285Z 1.1 GB kicad-5.1.2_1-x86_64.exe
2019-06-05T23:33:26.911Z 1.1 GB kicad-5.1.2_2-i686.exe
2019-06-05T23:35:05.772Z 1.1 GB kicad-5.1.2_2-x86_64.exe

These are both the same KiCad version, but one is bundled with an update to spice.


#10

I Sprig,
Thanks for your reply! I took your advise, and warped it slightly, I Built a VM Windows 7 machine and installed the same version of KiCad I am running. Copied over the project folder. Okay there are a couple of symbols and footprints missing, I was able to successfully open the project folder and load both the .SCH and the PCB, and the 3d viewer worked. This VM is NOT on my main PC but I RDPed onto it from my PC.

The Graphics card on this other machine is not very powerful (as its a software version of a GPU). so I got a warning that there was no openGL support and it would switch back to rendering. But I could open the file so I am glad to report that the file is not corrupt!

So, that moves me back to the main PC, which is a I9-9900K 32GB Ram, Windows 10.0.17763 and as I said its fitted with a Nvidia GTX1060. I am using the Nvidia Drivers and not the Microsoft ones.

Going back to the original posting “How to make a clean Restore of Version x” How to remove KiCad from the machine in its entirety including a registery clean-up, so that the Wintendo 10 Games machine (Pun intended) cannot detect any residue to the KiCad system ever being installed.
I then intend to roll back the Video drivers pre-when my GPU had a meltdown (Including Burning Fibreglass PCB) and start again.

So, how do i remove KiCad totally?

Mat


#11

Windows STABLE downloads are NOT NIGHTLY BUILDS !!!


#12

These are the KiCad files the OP states as using:

These are the official KiCad stable versions of 5.1.2:

Neither of these dates:
05-15-19 download (1,171,336 KB)
07-04-19 download (1,171,365 KB)
match either of these dates:
04-24-19
06-05-19

The OP never mentions using the stable version. It is possible that that the OP downloaded both 5.1.2_1 and 5.1.2_2; which would account for the different file sizes.

However, as seen in my post above, the files are clearly marked with their version:
kicad-5.1.2_1-x86_64.exe
kicad-5.1.2_2-x86_64.exe

It is common practice for members to include the date (or jenkins) info when using a nightly build.

Unless the OP comes back and clarifies, it appears to me that the information presented can be interpreted either way and it’s not possible to know from the OP what version was being used.

However, due to curiosity, I checked and I have the kicad-5.1.2_2-x86_64.exe file on my computer, and it is exactly 1,171,365 KB in size.


#13

He gave the dates he downloaded the stable versions. He is not using nightly versions.

Either way, none of this discussion is helping the OP.


#14

In my opinion it is a good example of why the KiCad version being used should be clearly stated.


#15

Hello Hermit,
No, did not try raytracing. Did not do anything that i had not done numerous times before.
That’s why I am surprised and confused.
Thanks much for answering.
JohnR


#16

FOUND ANSWER to my question: How to make a clean reinstall of Version 5.1.2.

Since reinstalls did not solve the problem, it became obvious (finally) that the KiCad uninstaller does not remove everything.

So, installed REVO UNINSTALLER, a program that I used 6 years ago, with good results. Free copy would have worked, but downloaded 30 free trial ($30 after that).

When I had REVO uninstall KiCad, it showed 200KB remaining after step 1, which is to used KiCad’s uninstaller. Then I had REVO remove the 200KB of JUNK!

That junk is what was causing problems after KiCad reinstalls.

Reinstalled KiCad 5.1.2.
EVERYTHING IS FIXED!

Thanks for everyone’s help.

John


#17

I still believe you might have clicked that toolbar button by accident or hit some hotkey, although I don’t have KiCad at hand to verify if the choice is persistent or if there’s a hotkey for that. The symptoms are the same.

This FAQ article would have told how to clear the setup: Where are the configuration files (settings, library tables)?

KiCad itself doesn’t store anything in the registry. The installer may set some environment variables which are seen in the registry if you have chosen it to do so. When KiCad is running Windows sets some registry values related to KiCad but not KiCad settings per se.


#18

I’m fairly certain that I have had the same problem in the past, while running Windoze 7.

I can not imagine that KiCad and Windoze play any nicer at this point in time.


#19

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.