How to get rid of the component type names eg "Conn_01x05" on PCB layout


#1

I find it irritating that when laying out a PCB the component type names are there in full splendor and glory - I don’t need them. They are obnoxious and in the way.

Yes, I can individually go into each component and shrink the text into almost invisibility.

Yes, I can (I hope - we will see when the board gets back) I can suppress them from being part of the top silk.

I want the part ID (“J5”), of course. It should be on the silk. It is part (in a light grey) of the component itself. (I want it by the component, not on top. See J31 in the picture).

I also know I can go into the ASCII file and do a basic search/replace of the text size to 0. Not recommended, especially for those who are faint of heart (and sloppy with backing up).

So - is there any way I can stop seeing the text (in the example, “Conn_01x05”, Conn_02x05_Odd_Even", “Conn_01x02”) when I am laying out the PCB?

I can see where clutter like this would get really irritating for a high-density board.

(I looked at the topics but could not find this question. Nor could I find a good method for searching, although both could be pilot error.) (Found the Search - duh - definite pilot error.) (did the search, no joy.)

Thanks!


#2

Those “component type names” are called Values, and they are on the “Fab” layer, not the silkscreen layer. So they will only show up on the screen, not on your physical board.

But yes, they can be annoying on the screen. To hide them, go to the right side of the screen where it says “Visibles,” and select the “Render” tab. Then just uncheck the “Values” checkbox.

pcb-visibles-render


#3

The “~” symbol, even as far back as fields in the schematic, has some interesting quirks.


#4

You can also simply hide the Fab layers.


#5

That works exactly like I wanted it. Bless you…


#6

I am using the default settings. When I turn off F.Fab, all yellow footprints go away, leaving only grey outlines. Interesting enough, the very yellow text I want to go away - they remain.


#7

Do tell… inquiring minds and all that…


#8

Sounds like you’re on Kicad 4.0.7. That’s been fixed in 5.0.


#9

Yes.
When does 5.0 come out? 4.0.7 was the latest I had access to a month or so ago.


#10

There’s a whole thread on that… :slight_smile: