How to add footprints


#1

Hello!
I have (hopefully) finished a schematic and would like to move to PCB.
I exported a netlist and tried to import it into the PCB window.
I have a bunch of messages like this:
Error: Cannot add new symbol “J3:/5A5C06A2/5BFDD088” due to missing footprint “”.
Error: Cannot add new symbol “R8:/5A5C06A2/5E9236C8” due to missing footprint “Resistors_SMD:R_0603”

So I wanted to assign a footprint for example to this second line (it’s a resistor, let’s start simple).
When I double-click the resistor, a window is brought to the screen. When choosing footprint in the
center pane, the right part becomes field value : resistores_SMD:R_0603. When clicking browse
footprints, a large window with “kicad footprints maste” as a single line on the left column

What am I suposed to do? Clicking kicad-footprints-master doesn’t seem to work, It shows the
path where I downloaded and expanded the library.

Thanks for any hint!

Pascal


#2

Check out the forum faq

Particularly this topic: How can i assign a footprint to a symbol?


#3

Hello Rene!

Thanks for your reply. I was already looking at that page when I wrote the question.
Just in case somebody else has the same problem. When you use PCB’s “manage footprint
libraries”, you have to add all the libraries which are stored in the packages you downloaded.
In my case, I downloaded “kicad-footprints-master”, unzipped it.
Go to PCBNew, open Preferences->Manage footprint libraries
Then there is a button “browse libraries”, navigate to the root of the libraries you downloaded
(in my case : “kicad-footprints-master”) and inside of this folder, choose all the libraries
you want to add.
My mistake was to choose the root itself, not the libraries.

Thanks,

Pascal