GND Copper fill top layer and pad connections


#1

I am noobie to kicad and following some tutorial to build attached layout.
I could not understand why there are lines (circled in yellow color) connecting to edge of filled zone to pads which are connected to GND?


#2

@ChrisGammell is a member here and it is his tutorial. Perhaps we can summon him up for you. I watched this a while ago. Without the working model in front of me to turn off the ground plane and zoom I’m not sure what’s going on.


#3

I believe it is an issue that shows up in legacy canvas on Macs, see this thread:

https://forum.kicad.info/t/are-these-lines-in-the-copper-pour-normal/3086?u=1.21gigawatts

Does it go away if you switch to OpenGL canvas (press F11 to switch to OpenGL, F9 to switch back to Legacy).


#4

We had a similar question a while back. I think the resolution has been that this is a rendering artefact on Mac.


#5

Thank you for quick reply and I am amazed to know that I am following tutorial from a member of kicad community.


#6

Oh great, opengl rendering mode fixed this issue but text for pad name and net name is too tiny to read now (please see attached image).

If there are issues on MacOSX, I hope windows VM would be great for kicad!

Thank you all for quick resolution. There is great community support for kicad and now I am confident to go ahead with kicad for all my pcbs.


#7

I think this is the video where he connected and extra pin to ground so be careful if you actually build the circuit. :wink:


#8

…all part of the magic, right? :smiley:

I actually had a request to do GTB in the OpenGL canvas, might give that a shot this week.