Getting Started step 50: footprints not getting linked to symbols

(I’m not sure if this Q is best under the Software category, or under Layout>Footprints)

Never used KiCad before, going thru the Getting Started tutorial, at step 50:

  1. Cvpcb allows you to link all the components in your schematic with footprints in the KiCad library. The pane on the center shows all the components used in your schematic. Here select ‘D1’. In the pane on the right you have all the available footprints, here scroll down to ‘LED_THT:LED-D5.0mm’ and double click on it.

As you can see in the attached pic only Symbol 5, U1, is populated with a footprint.
Also, when I press ‘e’ on a resistor in my schematic, no footprints are available for even a resistor. From what I can see online, I should see many options for resistor footprints here.

It seems, there is a standard library of footprints that is not being pulled into KiCad?
Tutorial doesn’t seem to say I have to do anything special to add any libraries at this point.

This is KiCad 5.1.12-1-10_14 on Mac, if that matters.

Your list of “Footprint Libraries” is empty (Except for that “general” thing).

There should be a long list of libraries over there.
There should be some 100+ libraries, linking to 20.000 or so footprints:


This means that the default footprint libraries are not properly managed, and there are (at least) two common causes for this.
Sometimes they are not installed at all, the other common cause is that you clicked on “no” or on “cancel” when KiCad asked you to generate the library tables.

The first (not installed) is easy to check in the installed size of KiCad. A complete install is around 4GB, while without the libraries it’s probably less then 1GB.

The easiest way to fix the second cause is to exit KiCad, Then go to your configuration directory and then delete the “fp-lib-table” file. Then start KiCad again, and when you do something that is related to footprints, it should ask you if it should generate a new fp-lib-table file.

The link below has a lot of info concering library management in KiCad.

Thanks for your reply. Did lots of digging …

So my laptop has a 6 GB “Application Support”/kicad folder. In there I found modules/Resistor_SMD.pretty/*.kicad_mod which must be footprint files, and many other components, so I clearly have the stuff installed, but KiCad is not finding it.

Attached pic is screenshot of CvPCB’s Preferences>“Manage Footprint Libraries”. It shows my fp-lib-table should be at /Users/psommerfeld/MEGA/work/pcb/peter/fp-lib-table, but that file does not exist.

Restarting does not ask me to generate anything. Is this the root issue? What should fp-lib-table look like?

The paths at the bottom of the pic are correct, but no libs are listed. I manually added the /Library/Application Support/kicad/modules/Resistor_SMD.pretty and then I could associate the footprint for my resistor component. So somehow the list of libs does not get populated.

So I downloaded the the latest fp-lib-table and footprints from
This fp-lib-table has everything populated as I guess it should, so I copied that file to the file location KiCad indicates it uses.
Any idea why this was not during install time??

For anyone else running into this issue, I found a write-up of basically what ended up doing. The write-up is here:

Maybe the Mac install has some issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.