Get schematic items on grid without having to redo connections

Ok, I blew it.

While capturing a schematic, I had issues with symbol pins not being on the grid. So, rather than figure out what was causing that, I started using the control key so I could make the connections even if the pins were off grid.

I figured I could fix it at some point, once I got the board “done” and was just doing “cleanup”.

I can select everything, right mouse click, and then do “Align Items to Grid”. When I do that, I loose almost all the connections.

Do I need to redo the connections, or is there a way for the pins to get shifted to the grid and maintain connections–probably not, since that would take diving in the schematic symbol?

It’s not worth fixing if it’s not easy. I’ll just ignore all the associated ERC warnings.

Does this mean creating a schematic using symbols from Kicad or personal libraries, or does it mean importing symbols?

When using the Align items to Grid, if the pins are attached properly to wires, they should stay attached to the wires.

Can you post screenshots of “before” and “after” the “Align to Grid” function?
I have seen it create shorts, when wires overlap after the alignment, but I have not yet seen missing connections.

JMK also has a point with the origin of those symbols. KiCad’s own symbols are designed to align on a 100mil grid. If your symbols do not adhere to that convention, it will just stay a mess.

UPDATE: My bad I did mentally shift to PCBs.

Nothing “needs” to be on grid, one could shut the grid off and just place parts where you think they should be. I wouldn’t design a board without the grid, but its possible.

Besides, on many parts the distance between pads is not the same as the grid, making at least one pad off grid.

Aesthetics aside, I’m not sure but I think the only benefit of having all parts on the grid MAY have some effect on the automated parts location for high volume boards.

I think you may be conflating schematic and pcb

I agree. And inflating them would make them bigger.

Indeed the OP was discussing schematics and not pcb layout.

off grid

I agree they should, but they don’t.

As Paul writes:

The video is too difficult to decipher. Too small, can’t see the start. Can’t read the ERC etc.

Only point of the ERC is that the pins with the red arrows are unconnected pins. Can you not see all the red arrows?

Anyway, the before:


After with ERC flags;

I assumed, from your first post, you were losing connections between wires and pins; but you are losing your labels.

Attaching labels with the symbol and wires ON grid (without moving anything) gives the same error when running ERC.

I’m not sure if this is a bug or incorrect use of labels ( I rarely use labels and never run ERC).

Others may comment, I hope. :slightly_smiling_face:

Both labels and pins become disconnected. Note the ERC has both types of errors.

The screenshots do clarify some things. From

I thought at first that complete wires went missing, but it is “just” small misalignments as usual.

What is the grid setting?
I am not sure what the result of Align ltems to Grid would be if you align things to a non compatible grid. Setting the grid to 1.27mm (50mils) before you do the alignment is usually the best option, and from the horizontal line lengths I see you have some other (smaller) grid setting.

Video quality is adequate, but it gets scaled down by the forum software. I also had some trouble watching it, but that was because I disabled animated gifs. It’s too often used for moving advertisements, and I’m allergic to those.

I’ve tried several grid settings. Right now I’m using 50 mil grid.

I think the symbol is from the Kicad library (MCU_Microchip_ATtiny.

But, several symbols from Kicad libraries do the same thing (

Yes, I notiece that one was at least a very good look alike :slight_smile:

Can you zip up and post the project (or at least the schematic?). Then we can have a go at it and see if any troubles arise.

Another thing you can try is to:

  1. Exit KiCad.
  2. Rename the configuration directory. (Location depends on OS).

When you delete KiCad’s configuration directory, KiCad assumes it is started for the first time and creates the configuration directory with default settings. This way you can easily check whether there is any problem with settings you changed. After the test you can rename your personal settings back to the original name to get all personalization back.

Is the configuration directory where the “save as” goes to when saving a project? If not,how do I find it?

No, the configuration directory is completely separate from any projects. It only has global settings for KiCad.

On my linux box, the configuration directory is in: ~/config/kicad/8.0. On windoze it is in the Appdata directory (I think). I don’t know where it is on the fruit os.

The folder where the binaries are located ?

KiCad stores the settings files in a folder inside your user directory. Each KiCad version will use a different versioned subfolder. For KiCad 8, those folders are:

Windows %APPDATA%\kicad\8.0
Linux ~/.config/kicad/8.0
macOS /Users/<username>/Library/Preferences/kicad/8.0

Also, when I searching forum posts, someone had a similar issue and was told to look at a box labelled something like “place components on this grid”. But, that was an earlier version of Kicad and that setting must be located somewhere else–I couldn’t find it.

I’m setting the grid differently than I’m used to. I’m using Preferences->Schematic Editor->Grids. Is this the right way to do it?