Gerber files created with KiCad 5 are bigger than KiCad 4 and show incorrectly in EasyEDA viewer


#21

For the record, both machines have the same Linux and KiCad version:

I’ll use the other machine try to generate gerber files for the original design where I found this problem and let you know what I can find with some more tests.

Thanks a lot for all of your interest.


#22

After completely deleting KiCad 5 and reinstaling it, the gerbers I generate look correctly in the EasyEDA viewer.

I have no clue about what was causing the the drill file problem. I thought it was because of a library I had to downgrade in order to compile the KiCad code (glm), but got back to the more recent version and gerber files still look fine.

Regarding the bigger gerber file size when using KiCad 5, I got the original board created with KiCad 4, opened it with KiCad 5 and generated gerber files, they’re still bigger in almost the same proportion I mentioned in my first post, I guess I can just forget about it since the files look fine in every gerber viewer I’ve tried now.

Thanks!


#23

There have been changes to way that arcs are translated to Gerber output, looking better but maybe a bigger file


#24

Thanks for the info @davidsrsb :+1:


#25

We just tried JLCPCB and got the same problem with the drill file. It seems to interpret the scale incorrectly. (Maybe one unit is interpreted as 1/10 of the intented size? I didn’t look so closely.)

I don’t know why it happens. After all I know I must presume it’s a bug in their viewer. I generated actually two boards (and two manufacturing projects) from one KiCad project so that I had two outlines in one kicad_pcb file. After the design was ready I created a git branch for each physical board just for plotting the gerbers and deleted the non-wanted board from the layout. I generated the gerbers and the drill files with the same settings. But weirdly only one of the boards had the problem in the JLCPCB preview!

I became wiser, did some searching and found their technical support for creating gerbers: https://support.jlcpcb.com/article/44-how-to-export-kicad-pcb-to-gerber-files. The settings which could be the culprit are Zeros Format and Minimal header. @mexchip has wrong zeros format just like I did. It could also be possible that Drill Units cause this.

(Note that Drill Map File Format shouldn’t have any effect because it’s for the drill map file, not for the actual excellon drill file. Map files aren’t usually used by manufacturers AFAIK.)


#26

I tested now with new settings and the board preview in JLCPCB is fine.

EDIT: it was probably the Zeros Format.


JLCPCB gives me warnings on .drill and edge cuts
#27

Yes, I just confirmed, when using “Supress leading zeros” zeros format the EasyEDA viewer fails to load the drill file, switching to “Decimal format” the gerber loads fine.

Thanks for the info!


#28

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.