Footprint's soldermask is missing?!

Hello there,

So I’m using this BQ76PL536A foot print that was available in one of the kicad libraries and when I switch to 3D viewer the solder mask doesn’t seem to appear…

is it just a bug in the viewer or an actual problem? this board needs to go to manufacturing.

even oshpark’s GERB view doesn’t manage to see it what is going on?

It’s probably an error in the footprint. BQ76PL536A doesn’t appear to be in the official libraries.

Where did you get it?

Sorry it’s here:

The version I have looks like this

What are you expecting?

The foot print’s pads manage to appear like that for me.

So what do you suggest?

I’m stumped! Clearly that footprint is unusable. How does it look in the footprint editor? Maybe some soldermask settings have got messed up.

Example pad:

For now I just need a quick fix should I just download the lib from github and replace the file?

You could try that, the github version doesn’t seem to have changed significantly for some time.

What is on the “Local Clearance and Settings” tab for the pad?

Sounds like you may have hit this feature:

The footprint looks ok, but I would try reloading it into the PCB.

1 Like

The footprint is indeed defect.
It has clearance settings in the footprint settings enabled.

Fix commited:


Fix is merged with the library.
If you use online libs simply update the footprint on your board.

  • press e when above the footprint (opens footprint properties dialog)
  • press the change footprint button (opens change footprint dialog)
  • select change footprint of 'reference' or change footprint of 'footprint'
  • press apply

If you use local libs you need to update your libs. (Re run the library wizard to do so.)

1 Like

Yes it did it thank you very much!! how did you even find that github topic thing?

I created the pull request i linked because of your report here. (So it was new when i linked it.)


You said someone managed to fix it in a few minutes? nice! also is there an effective way to update footprints globally in a pcb?

In the change footprint dialog there is a selection for all footprints. This reads all footprints from the lib.

1 Like

Only one setting needed fixing. When i saw your post i first checked if the problem is with the footprint or somewhere else.
After finding the footprint is at fault i forked the repo and fixed the footprint in my fork.
Created a new pull request which was merged within a few minutes by one of our library managers. (I’m not allowed to merge my own pull requests)
Another manager found another problem with most of the footprints in this lib. (Wrong naming convention. The “_” before 1EP should be “-”)