Footprint Editor display issues on MacOs Catalina

I recently downloaded KiCAD 5.1.7 on my Macbook Pro and started following a tutorial on YouTube. When I got to footprint editor to learn how to create a footprint, I tried opening the footprint editor. It loads all the footprints and opens with a white screen in the center with the basic libraries and commands on each side. However for some reason, it shows all the footprint libraries already available with footprints in them but it will not show any of the actual footprints in the center screen, even after double clicking on them. Then I checked my application folder and saw that Footprint editor application did not come with the download. I am not sure if that is the problem.

I tried redownloading KiCAD (now 5.1.8) and still the same issue. I would appreciate any help on this issue and would like to get it resolved.

The footprint editor is part of pcbnew.exe, so that’s not the problem.

The footprint editor should look like this (EDIT: on Windows):

If the view which is black in the screenshot is white there’s some problem with graphics rendering. Do the schematic editor, symbol editor, layout editor and gerber viewer work correctly?

I have used the schematic editor and symbol and they work file. I have not used the gerber viewer yet since I am still starting out with KiCAD. How can I fix the footprint editor issue where it only shows a white blank screen?

3D Viewer seems to work

You’ve got one of those monitors with those ridiculously small pixels…
There have been issues with those before, maybe you can find them on this forum if you search for it.

You can also experiment a bit with:
… / Preferences / Preferences / Common / User Interface and then “icon scale”, “Canvas Scale” and the other settings in that part.

It’s the retina display from Macbook Pro. However, let me try those things you mentioned, and I will get back.

Yeah, no change at all.

Try to switch to fallback graphics rendering. Should be in the preferences menu or reachable via some hotkey (F11 or F12). If this solves it then a graphics driver update would be an option to get opengl rendering working again.

I tried switching the multiple options in the Fallback setting, with no luck. Still the same white blank screen.

What is the exact version of your operating system?

MacOS Catalina, Version 10.15.4

Please try the accelerated modern toolset. If you are on a Retina display, then you will need to use the accelerated version otherwise you run into issues with the canvas being the wrong size.

Not exactly sure what you mean by that?

Simple answer: Press [F11]

KiCad has different ways for rendering the GUI built in and you can switch between them with F11] and [F12].
You can also find these in the menu of most KiCad sub programs in the main menu under Preferences

The issue still persists.

I sadly have no expirience with Mac. I edited your post title to make it clearer what is going on so hopefully somebody who knows something gets interested.

You can also make a bug report over on gitlab as what you see should not happen.