Footprint Assignment Page (CvPcb) Hanging Up ADDITIONAL PROBLEMS

The project uses hierarchical files. Something quit working. Now, I can not assign footprints. The page header reads “Assign Footprints (Not Responding).” The page lags, when changing functions and the footprint sub-libraries (far right side) may not open.

I thought the issue was with a recent upgrade to v5.01, so deleted it and installed 5.02. The original schematics were built in the last 4.x… 4.7, IIRC.

I also deleted the entire +5V Supply hierarchical, because that was what was stuck. I just rebuilt it from scratch. Then, I tried assigning those footprints. No joy… Same issue.

Next, I tried the 12V Supply hierarchical assignment. The fault is there, too.

How do I upload the project files?

Platform? Windows? Mac? Linux?

My apologies…
Windows 8.1/64 with all updates current.

I am encountering an additional problem. On a PCB board, when I draw a ground plane, it is blocking the front silkscreen items. The ground plane is properly assigned to the bottom copper and the proper net. This has never been an issue before.

This is best described from the example of a draw program. Say I drew a line and, then, I drew a square over it. If I want the line to show in the square, I must arrange the square to be on a layer lower than the line. Here, the line would be the front silkscreen and the box would be the bottom ground plane pour. The box is covering the line, even though KiCad has always oriented the two correctly automatically.

I am properly updating the screen, by redrawing it… Control B and View/Redraw.

Thank you for your help.

At first glance, this appears to be a KiCad Environment Variable issue… but I reserve the right to be horribly wrong.

Agreed… I don’t think that this is a settings issue, or op error… That’s why I am posting. Any firmware issue is above my pay grade… Thanks for your help.

I found a work around for the layer issue… Draw the ground plane, save the file, close and open the program… The ground plane is then oriented correctly below the front silkscreen.

The layers are meant to work so that when you select a layer from the rightmost panel “Layers Manager/Layers”, the selected layer is visible above the others.

You can and usually (while routing) should keep planes/zones in outline mode, that can be toggled from the left side toolbar.

1 Like

I quote the development version (for the future 5.1) of the Getting Started document:

Note: There are many more ways to add footprints to symbols.

  • Right click on a symbol → PropertiesEdit Footprint
  • Double click on a symbol, or right click on a symbol → PropertiesEdit Properties → Footprint
  • ToolsEdit Symbol Fields
  • Check Show footprint previews in symbol chooser in Eeschema’s preferences and select the footprint when you select a new symbol to place

Even if you would prefer the good old Cvpcb, i.e. Assign Footprints application and there’s something wrong with it, at least you can do the assignments in some other way.

1 Like

If you use version 4 or the version 4 library tables then it might be that you get your footprint libs directly from github. (Downloaded everytime kicad needs them. Example everytime you open cvpcb. This can take some time especially if your internet is slow or if github has server trouble.)

The suggestion is to therefore install libraries locally.
Have a look at this if you run version 4: How can i install a specific version of the footprint library?

And at this if you run version 5: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

This is only true while moving the item. Once it is set and de-selected, it should seat at the appropriate layer level. In this case, below the front silkscreen.

Neat work-around. I may give it a try.

Thanks for the link. I will give it a look.

I think this is how you want it to behave. I describe how it does behave. It it’s that way on purpose. You could file a wishlist report. But if you want more realistic view you can try the 3D view.

Is this different than the v4 series, because it did not operate this way before?

Ahh… Is it that when I make the bottom ground pour, after I need to switch back to the top layer. If so, what a rookie mistake. I will give it a try…

Doh… Yes, that’s it. I needed to go back to the top layer. My sincere apologies for this part. How embarrassing… I have been using KiCad for a good long while… I’m a Rookie, again… Thanks for straightening me out.

I am still working one the libraries…

It is easy to discover if this is the case. Open the library manager in pcb_new and check if you have any lib with the prefix Housings (example Housings_DIP) if this is the case you run the version 4 footprint libs. (These libs have been renamed to the better fitting suffix Package in the version 5 library)

No, all my libraries are KIGETHUB, or my local custom library file path. So, I could not understand from the instructions, if I need to do the Option #1 steps?

Thanks for your continued help.

Prefix KIGITHUB also means version 4 libs. (Version 5 libs do no longer support the github plugin)

Thank you. I will move on to Option #1 and post my results.

I appreciate everyone’s continued support, very much!

Yes, sirs, that cleaned it up. My deepest gratitude! You all are very gracious with you expertise, effort and time. How amazing, in this era.

I apologize for taking your time, on a known, published issue. My knowledge on this level of firmware was too low to even know where to start. I appreciate your patience.

Now, back to the fun of playing with KiCad!

1 Like