Footprint Assignment Page (CvPcb) Hanging Up ADDITIONAL PROBLEMS

Well, everything worked properly, for a while. Then, I shutdown my laptop for the afternoon. When I started the laptop there were no problems.

Now, no PCB file will open from any project. When I click on one, the program acts like it has gone off to open it, but nothing happens at all. There is no fault code, or blinking, etc.

I have tried rebooting, even disconnecting power (the battery has been long removed.) So, I would appreciate your help with what to do next. Thank you.

I did a fresh install. TIme will tell. Thank you.

EDIT: After the install, PCBnew opened once and accessed a project pcb. Then, I tried opening a KiCad project and accessing the pcb. The full problem returned. The pcbs are not opening, but, when you try to open another pcb, a pop-up says that a pcb is running and asks if you want to continue. Thoughts?

You can just continue, KiCad can have multiple instances open at the same time. But it probably doesn’t help if you can’t open some project with even one running KiCad.

If pcb new does not start up then you might have run into a bug.

You could try switching to a different canvas (now called toolset). Maybe your problem is concentrated to only one of them. (my guess modern accelerated does not play well with your graphics card or graphics driver)

You can switch canvas on an empty project and then try opening the one you have trouble with. (switching canvases is done in the preferences menu)

If pcbnew does not even open in an empty project then you can still try and do this with a text editor by changing the config file (it is human readable.)
The config file is found in your users appdata directory (C:\Users\username\AppData\Roaming” + kicad)
The file in question is pcbnew.
The line responsible is the canvas_type variable.

  • Modern toolset accelerated is: canvas_type=1
  • Modern toolset fallback is: canvas_type=2
  • Legacy toolset is: canvas_type=0

Correct… It was working as you say, then it stopped opening any pcb, from any project. Thank you for your reply.

Ahhh… Yes, I enabled the Modern Accelerator and then the problem appeared. And, when I did, IIRC, it shutdown the laptop… Either shutdown the whole thing, or just KiCad. Whichever, but there was a problem.

This is a great clue. I will work the problem from this angle and report back. You guys r-e-a-l-l-y know your stuff; thanks.

Okay, I had to bump around, a lot, but I think I have had some success… Here is what I think was the ultimate protocol that helped…

  • I am working with two pcbs that originate from a hierarchical project… I am panelizing them in a third PCBnew file.
  • Reset the Toolset to Legacy, as instructed.
  • Reboot to set the new Toolset default.
  • This allowed me to open PCBnew. At this point, the two PCBs would not open from the KiCad main menu. Do try to open them, here, or you will have to reboot to clear the opened/hidden PCB.
  • Open PCBnew to a new blank page.
  • Use the Open an Existing Project button to select one of the two wayward PCBs.
  • Use the Preference Functions to reset its Toolset to Legacy.
  • Repeat for the other wayward PCB. I think the panel did not require this procedure, because it opens under PCBnew, which has already been reset to Legacy.
    I think that the wayward PCBs will open from the KiCad main menu, now, but more testing is needed. I will let you know how it goes. Thank you, so much.

The PCB problem returned, even though the ToolSet is configured to Legacy. My laptop is old and its battery is dead. Time to get a new one. KiCad is too much fun to fool around with aggravating hardware issues. Gotta move on; we’re in the middle of designing a Function Generator…

This is my (bad) card info?
Mobile Intel® 965 Express Chipset Family (Microsoft Corporation - WDDM 1.1)

Thanks for the help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.