Fighting for weeks around libraries


#1

Hello,
I’m using the v5.02 version of kicad from a fresh install (done about 10/12 times) :smiley:
I have forever the same issue, ALL I said ALL THT footprints library missing.

So I tried to download them from http://kicad-pcb.org/libraries/download/ & install them to /usr/share/kicad/library & /usr/share/kicad/modules depending of the files as usual.

I start then the kicad application & setup all my paths but they are never loaded.

I tried again from this morning without any results.

I am really stuck on that point & doomed to use EasyEDA until I can run kicad locally on my workstation.

PS: if I build a unique componnent lib from component editor all is fine.
I can build & load it & its footprint

I read all the FAQ & many post about library issues but this doesn’t help & (http://kicad-pcb.org/libraries/contribute)


#2

Hi francois,
since i don’t know what you already tried, let’s start at the beginning:
KiCAD does (as far as i understand) not import files automaticlly, regardless if they are in a path specified in the librariy editor or not. What you have to do is to add the librarie to the “List”. You can do that or check if they are already their by opening the librarie editor and then under “preferences” select “Manage Symbole Libraries”. Under the tab “Global Libraries” you can add an Alias for your librarie and the full path pointing to it.
After that you should be able to use ist.


#3

You might want to read Library management in KiCad version 5

TlDr: setting the paths is the least important part. KiCad does not really have a special place for libs to go. You only need to tell it where to find libs. To do that use the library managers found it the preference menu.


But the default installation should have taken care of this. your paths look like linux paths so you might not have installed everything.

Most platforms give the user a way not to install libraries. in linux this is done be having the libs in a separate package. You might therefore be interested in I installed KiCad 5 (under Linux) but there are no libraries. (The default option for sym lib table setup is disabled)


#4

I can go & check kicad registered properly datas after setting path from interface
doing

So it is written properly

the bug or issue percist .


#5

The library table uses plural names. So kicad version 4 libraries.


#6

I do not like downloading software from the internet and installing it much on my linux box, even if it’s a relative trustworty program such as KiCad.

For me, installing KiCad is something like:

sudo apt install kicad kicad-demos kicad-footprints kicad-libraries kicad-packages3d

Edit: To all nitpickers:
This was (probably) not the exact command I used to Install KiCad. Almost certainly I first installed most, then discovered it was incomplete, did an “apt search kicad”, found the missing parts, and also saw there were “demo’s” and other goodies which could be fun to play with, and added those later. The main idea though is that KiCad is divided over multiple packages, which gives the user controll about what he wants to install.

Installing “KiCad” 10x and then also making the same mistake 10x is not very productive.

One of the most probably causes is that Kicad only looks for the libraries it’s told to look for. If I look at:

Pcbnew / Tools / Manage Footprint Libraries

Then I see a whole list of footprint libraries, and if footprint libraries are not listed here, then KiCad will simply ignore them, now matter how many times you install them.


For how to resove this, the FAQ entries written by Rene and his links posted above are much better than I could write here.


#7

Just a small nitpicking … if you choose the metapackage kicad-libraries you don’t need to explicitly add the depending packages kicad-footprints. The package kicad-libraries is depending on the most typical used libraries for KiCad, at least in the distributions based on Debian like here Mint. You can always check such things by using the apt command (or your preferred package manager).

$ LANG= apt show kicad-libraries | grep Depends

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Depends: kicad-footprints, kicad-symbols, kicad-templates

To have an visual overview about the directly packages around KiCad I’ve made a graphic months ago to visualize this while working on the packaging for version 5.

KiCad package relationship in Debian based systems


#8

Ok with that so I redone it all on this morning again,
then the issue comes back to the first state, *THT and only *THT footprints doesn’t work


#9

Does not work is not really a good problem description. Describe what you did, what you expected to happen and what actually happened.


#10

does not load
just like if thoses lists were empty without any footprints inside
all other SMD for example are OK


#11

SMD are OK
but not THT


#12

the assign footprint tool is not really the best option to check if a library has assets in it. Use the footprint editor or footprint browsers for that.

Do the files exist on your machine? (Check where the library table points to and make sure there are files there.)
Do you get any error messages when starting the footprint editor?


#13

YES and YES files are present & set well as mentionned above, I compared the file ~/.config/kicad/fp-lib-table to the /usr/share/kicad/modules/kicad-footprints-master directory content so this can be considered as “absolute truth” computer point of view

:slight_smile: this is really unbelievable :slight_smile:

so both are present
and both are declared

there are no differences between THT & SMD in truth out of files generated by using interface so I hope I can pretend having done all right in interface after installation.

I can understand ALL is blank or ALL is missing but I cannot understand only THT are missing


#14

Did you check in the footprint editor? And most importantly: do not only check that the .pretty folders are there but that they have .kicad_mod files in them.

Oh and by the way: what is your kicad version?


#15

of course I also checked the mod files are in folders I m not so stupid or tired :smiley:
I can use the footprint editor for new ones & loading existing ones, but not THT
and my version in 5.02


#16

is it possible that the project local library table contains libraries with the same nickname?
Also check the file access rights. And try to rename one of these libs and see if you get an error message.
You might also want to try to delete the fp-lib-cache file in the project directory.


#17

Good ideas I’m going to check that.


#18

This may be clear to you, but how are we to know?

With these problems it is often not vey usefull to speak in general terms such as “all THT” components are fucked up. Instead, If you focus on a single component with which you have problems, then you will probably discover that all the other missing components have exactly the same problem.

So I open a schemtic, and add a resistor:
1). “a”
2). (slight delay for loading libs)
3). “r” [Enter]
4). [Enter]

First enter selects the resistor in the library, second enter places it in the schematic.
This default resistor does not have a footprint yet, so you hover over it and:
5). “f”
6). [Select]

This gets you into the Footprint Library Browser, where I select a random THT resistor:

In the title bar I see the library is:

/usr/share/kicad/modules/Resistor_THT.pretty

and the component I selected is:
/usr/share/kicad/modules/Resistor_THT.pretty/R_Axial_DIN0204_L3.6mm_D1.6mm_P5.08mm_Vertical.kicad_mod

So I opened a file browser, and checked that this file exists, and it does. The files in the file browser seem to be just the same as the components in the Footprint LIbrary Browser.

Hmm, maybe I’m taking too small steps here, but you get the idea. If you get stuck, then describe all steps you did in detail, you may have missed some.

You have cut the title bar off of your screenshots, but your screenshots appear to be from CvPcb. Describing library problems with screenshots from CvPcb is not very productive. There are a lot of filters in CvPcb which sort and limit the libraries and components you see in CvPcb.

The first step for you seems to be to verify if the footprints files are on your HDD.
You can do that with a file browser, command line window or by assigning a single footprint with the Footprint Library Browser.

Try that, and then well see what the next step will be.


#19

this is exactly what I mean ALL THT components have the problem, after many investigations doing just as you said very minimal checks/steps before I decided to open the topic :smiley:


#20

Maybe you have some filters on.
Try playing with them

filters