Fighting for weeks around libraries


#21

This is exactly what I mean.
Saying again and again that “ALL THT components have the problem” is not usefull at all in diagnosing anything. Neither does doeing lots of small steps if you do not communicate which steps you did, which steps worked and which steps failed.

For example, you have been given at least twice hints to check if the .kicad_mod files (for some THT component) exist on your PC, and you have yet failed to report on checking this step.

To me that means it is time to get Eric Steven Raymond out of the closet:
http://catb.org/~esr/faqs/smart-questions.html

A similar story, and also an excellent read is:
https://www.pjrc.com/how-to-get-tech-help-from-strangers-on-the-internet/


#22

this is false I justified that & checked it as mentioned what you want more ? a RDP to my host ??
I won’t do that

so I repeat with screen copy (partial)

OK so I need to post a screencopy of each click … :slight_smile:
-permissions are OK
-files are OK

@Pedro, no I have no filters activated

@Rene_Poschl : I will also try to delete the fp-lib-cache files for projects

I will tomorrow do a full step-by-step post


#23

We’re getting confused between two common issues

  1. installing libraries. To verify you have libraries installed you should use the library browser, not cvpcb or assign footprint.

  2. footprint filtering. Even if you have all the libraries installed correctly, the footprint filtering means that footprints may not appear for a particular component. E.g. if the footprint filter is “RES_*”, but all the library parts might be “R_*”.

Please don’t get passive aggressive when people ask for more information. They are trying to help you.


#24

There is a filter in the symbol definition.


#25

I never suggested anything like giving RDP access tyo your computer, and I do not understand your (seemingly?) hostile attitude.

No need to record / post every keystroke, but try to access your problematic libraries in different ways.
Are they visible in:

Pcbnew / Preferences / Manage Footprint Libraries / Global Libraries
(As I posted a screenshot earlier, but If you responded to that I must have missed it in the noise)

Can you access the THT components from the Footprint Editor or Footprint browser?
From what I recall you seem to have only tried it from CvPcb.


#26

francois already told us that they tested this:


#27

There were library changes that make THT modules incompatible, e.g. rounded pads. I think KiCad silently ignores invalid footprints. So it might look like footprints are “installed”, but the best way to tell if KiCad actually loaded them is with the library browser:

If you see footprints in the library browser, but not in cvpcb/assign footprint, it is probably filtering.


#28

It seems my mind is fogging up more then usual when trying to respond to this particular thread. Refraining from further posts in this trhead seems to be the best option for me.


#29

That would be news to me. Yes version 4 will not be able to open all footprint libs but this is mostly for SMD parts as we now use rounded rectangle. Version 5 can work with all footprints. Oh and kicad does not fail silently if the file format is wrong. It would give a parsing error message.


#30

LOL, got that backwards. I can’t think of any changes to the THT.

Which I guess makes it all a bit more mysterious.


#31

hello,

So I continued investigations on my side doing a fresh installation on another machine (virtual one) then I have no issue. So here is my test protocol done exactly similar on the host machine :

So I installed binary packages on the host (having previously the issue), then I downloaded the 3D shapes ; the footprint & the symbol zip files from https://kicad.github.io/symbols https://kicad.github.io/footprints & https://kicad.github.io/packages3d again.

I unzip all of the 3 packages in /usr/share/kicad/modules

I go to the interface, in preferences\configure paths I set paths

then I open the footprint editor

I click on file/open footpring

I click on select by browser

I select “Capacitor SMD” & one capacitor “CP_Elec_3x5.3” & it is displayed on the right side

I select “Capacitor THT” a then :
Screenshot_2019-06-08_17-39-35

I can select & compare any “whatever_SMD” with its corresponding “whatever_THT” with similar results

so I compared the /usr/share/kicad directory between host & virtual machine : I found no differencices

there are only 2 empty lines differences … I can ignore that.
So I think my linux box is the issue & not kicad until the virtual machine with similar installation is OK.


#32

what happens if you try to import one of the tht footprints into the footprint editor (file -> import footprint from kicad file)

what happens if you try to add one of these tht libs to the project local library table (use the footprint editor -> file -> add library, navigate to the lib, when asked which lib table then select local) Maybe give that lib a different nickname using the library manager.


#33

Hello,

I imported the file without error. I can test that on any file C_Rect_L9.0mm_W9.8mm_P7.50mm_MKT.kicad_mod , C_Rect_L9.0mm_W9.5mm_P7.50mm_MKT.kicad_mod & so on.

I set ActiveLibrary
I save footprint to active library that’s ok.


If I tru to add a tht lib to a local tab, from the footprint editor / file / add library this seems OK also.


In paralell I checked my /usr/share/kicad/ filesystem & reinstall it all from backup/restore for a faster action
now my kicad issue with libs disappeared… I did not find read erros in log files but It can be the source of the issue

I think I ve add linux issue & installation issue in first place

now all is OK.

thanks all of you


#34

By the way, and as a sideline, but still, those are interesting links your referring to, @paulvdh. I am sure they will come in handy :wink:

To me that means it is time to get Eric Steven Raymond out of the closet:
http://catb.org/~esr/faqs/smart-questions.html

A similar story, and also an excellent read is:
https://www.pjrc.com/how-to-get-tech-help-from-strangers-on-the-internet/


#35

I see too many repeated questions in this thread and lots of questions ignored or only half answered. For me personally I simply get lost in such a jumble, and the only way out and to keep my own sanity is to put in those links and refrain from further commenting on the content on such threads.

It’s a psychology thing. OP has some problem, and it’s inherently difficult to explain a problem if you don’t know what the problem is. Related to that, when writing down some text, details are always skipped, often because the seem “logical” or “straight forward”. But if there is some misconception in the base assumptions under a question, these also get skipped over for the same reasons.
When trying to examine those underlying base assumptions, It sometimes happens that the “other party” fiels belittled, or not taken seriously for “asking for the known road”.

Over the years I’ve read both those texts, multiple times, even though they’re quite long. I do not know if OP has even read more than a sentence of them. If he did, then it seems he has not bothered to give any feedback on it. Which is exactly the point of the whole thing. It’s a wild assumption, but it seems OP is to focused on his own problem to even notice the blinds he’s put on and those texts were “too far away” from his current problem to bother reading.

@francois_P
Now your immediate problem seems resovled, have a look at the links I posted.
These manuals on how to ask questions are written by experienced people who have seen a lot of mis-communications on forums, and have thought carefully about the misconceptions under these miscommunications.


#36

Absolutely, @paulvdh.
Been there, done that.
I meant it when I said those links will come in handy, one of these days.


#37

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.