ERC falsely reporting Pin Not Connected

Can someone help me understand what the ERC is trying to tell me?

Apologies for the way the images are posted, but as a newbie apparently I can only post one picture, so it’s gonna be a big one:

I have a fairly straight forward set of connectors to labels
but when I do an ERC it says Pin Not Connected

But if the pin isn’t connected then I would expect to see the little unconnected box on each symbol.

Also I tried to delete and re-route a new wire, but it still gives me the same error.

Note that if I drag (G) they stay connected. And I tried adding junctions but that didn’t seem to help either.

similarly, by using Highlight Net you can see that the net is very clearly connected but I get the error “Global label not connected”

I am attempting to get off Eagle and go to KiCad so am deep in newbie territory.

Version 5.1.12 on Windows.

Thank you for any help you can provide,


One thing to try: Make sure that your grid is set to 50 mils and then make sure that all the questionable items are set onto that grid.

Rest assured that your issue is not widespread; the vast majority of us are not fighting this issue (or any other particular ones that I can think of.)

Also…We are told on this forum that version 6.0 will be a stable release very soon, so it might help you to upgrade to that. It is presently listed under the “nightly builds.” Just install the latest nightly; I use the 64 bit “lite” version. Best to back up copy everything first as 6.0 files cannot be wound back to 5.1X

Thanks Bob, I’ll give 6 a try - since I’m just ramping up this is the perfect time to make the switch.

Showing 3 copies of J3 in your screenshot does not help much.
To me it looks as if some pins of J3 are connected to global labels, but those labels are not connected to anything else, and therefore KiCad assumes those pins are unconnected.

KiCad does depend on “perfect alignment” between attachment points of pins and labels with the endpoints of wires, and this is easiest to accomplish by working on a coarse grid as BobZ mentioned, but I think this is not the issue here.
You can verify if labels or schematic symbols are attached to wires by hovering over a label (or schematic symbol), then press g for drag, and move the mouse a bit. All attached wires move with the label (or schematic symbol). Then press Esc to cancel the drag, and the label (or symbol) goes back to it’s previous position.

1 Like

Look at those coordinates in the ringed text. When I see something like 115.57, I know that you have been using something much finer than the default 50 grid.
There is almost no reason to change the default and I wish it was made much harder to do so.

I routinely use a finer grid for positioning text such as symbol values and reference designations. I like to make a relatively “tight” schematic, and good positioning of the text helps with that.

I am thinking about proposing a wishlist item for dual grid in schematic, allowing a fine text grid, while keeping symbols almost locked solid at 50. Nudging text is the only valid use of a fine grid that I can think of.

1 Like

Thanks. That sounds good.

Feel free to support it

I was also doing it until someone here told me to use CTRL+SHIFT to do it. Since then I never change grid in schematic. I have written about it at least 2 times last 3 months, I think.


It looks that ‘mode’ is connected to pin4 of J3 and to pin 14 of something. What is that something?
I just consider if it is possible that that something is from ERC point of view nothing.

Thanks. That seems to work. Is it switching or just disabling grids? Is it described somewhere in the menu or list of shortcuts? Those two keys are often used in this list…but I do not see what you say (even though it indeed works)


It is all somewhat confusing because CTRL+SHIFT also is used to de-select items from a group selection. I wish they were all documented in one place.

And in 6.0 I find that if I move too slowly, it will often move items that I do not want to move, without me pressing the M key.

Just disabling.

I don’t know. Before first KiCad installation I have read all pdf-s (4.0.7, but they were not up-to date) and I didn’t know that until someone told me it here (I think it was in 2018). May be I just overlooked it somewhere because if you read about software you even didn’t tried to use you just don’t know what is important to remember.

1 Like

@Piotr and @BobZ, there are two separate modifiers: Ctrl disables snapping to grid, and Shift disables snapping to other objects. Therefore holding Ctrl+Shift disables snapping to everything. It also won’t show up in the hotkey list if you search for Ctrl+Shift, but both should show up individually if you search or scroll to the bottom.

see incomplete 6.0 docs here:

and edited because I got them backwards :roll_eyes:


@dmetzler If you are still having this issue, it’d be helpful to upload your project. I know you’re a new user but perhaps a mod can bump you up a level, or you should be upgraded soon just by reading some other threads.

Thanks a lot for the explanation @gkeeth

I have difficulty to remember some of these “keyboard shortcuts” (unsure if we are discussing a keyboard shortcut.) A big issue is different commands for different software. I am now in the habit of zooming in KiCad with F1 & F2. (My trackball has no scroll wheel and I am reasonably happy with F1 F2 zooming.) But then I will be running some other software and hit F1 which requests help.

HERE IS ANOTHER IDEA…IS IT FEASIBLE? How about when I select some text and hit the M key to move it, something pops up (visible but a little bit out of my way) to tell me about Shift, CTRL, or other available function modifiers?

I’ve been handing out “likes” for this “control/shift”. I didn’t know about it previously.

My favorite trick was to run the grid down to 1 or 2 mil. to relocate component text, then forgetting to change back to 50 mil. when I add or move symbols. :slightly_frowning_face:

I doubt I could survive without that “undo” button… it saves a lot of cursing… just one !@#$%^ and hit “undo”. :grimacing:

And perhaps an audible “beep”… just to break that deeeeep concentration? :grinning:

Reading the forum continuously is a very good way to get skilled in using KiCad even not practicing it.
You never don’t know what you don’t know. You can find here answers to questions you even didn’t thought to ask. I don’t use KiCad frequently (last PCB I have finished 1.05.2021) but I read the forum to be be up to date.

1 Like

So do I; but I missed this one, or forgot.