ERC errors won't stop!

Connected all the components and they appeared to be actually connected but when I run ERC there is errors, I have been able to correct some down to 2 or 3. Try to correct them then other ones come up!!!
I’ve spent days and hours trying to figure this out but nothing works!!! Can’t stand this any more!!!
Desperate for help before I delete KiCAD!!! The progammers that created this need to get busy and correct the bugs!!!

If you want to get help and not just rant at the unfair universe then you need to be a lot more specific with your problem.
Add screenshots/schematic files and show exactly what steps you are performing and how the result is different from expected. Oh and specify the full kicad version.

On the off chance that there actually is a critical bug in latest stable version you can rest assured that devs will be on top of it as soon as it’s properly reported.

1 Like

It’s not just me that’s having this problem.!!!

How about you post about your problem with the supporting files and let the other people fend for themselves for now?

ERC is just a helping tool. You are free to ignore errors and warnings of it if you are sure your schematic is correct. Some of its errors are simply: “I am not sure if this is correct and that is why i make you aware of it”.

Also be aware that ERC is a net based tool. It checks the electrical types of pins connected with each other against its internal connection rules. It has no knowledge of your components functions.

For any more detailed help we at least need the message you currently do not get rid of.

And, for what it’s worth and for your information, the developers are already aware of the many shortcomings of the ERC system and many things will be different in v6 when it will be released.

This seems to be the 3rd post about “random” ERC errors popping up.
In the first thread I read the ERC errors mysteriously disappeared a day later.

I’ve been watching this forum for some time, even made 2 bug reports myself and the volunteers developing KiCad seem to be very responsive to good bug reports. It usually means that if you make a bug report with a reproducible bug, then it will be fixed within days or weeks. This is quite extraordinary for an open source project, and one of the reasons I like KiCad very much.

So, if you can reproduce the ERC bug in your schematic, then please make a bug report on gitlab and upload your project or part of it which shows the bug.

I would not bet on bugs to be honest. ERC in the stable version works quite well within its own constrains (it had a lot of time to stabilize as it did not get new features in ages).

And without further info we can really not do much here either.

If all you seem to be prepared to do is rant on about bugs in the program without properly describing either in words or using the standard way by including a screen shot of the .sch showing where the ERC errors are appearing, how do expect the rest of the users to help.
How do you propose to report it to the developers as a bug either.
I GUARANTEE that 1 screen shot on here the problem will be solved!

Calm down ! Im new to CAD in general, but I have made several boards and they look and work great and I have never found any bugs so take some of the great tutorials that are pointed out on this forum.

Yeah it is, other people with problems state what they are, clearly and concisely.

Hello, I’v been trying to get the “Print Screen” function to work but it won’t. Goggled it and tried the appropriate key(s) but no reaction!!

Good for you! You have the ability to learn quickly!! I’m old but not that old. haha I’m a slow learner.I love to tinker with electronics. I did EASYEDA for a little while but to export to printout pcb the tracks would not finish to the pads or pads were out of position!!!
Started with KiCAD 2 to 3 weeks ago but it has proved difficult for me.

What operating system are you running?

I’m running Windows 10!

The print screen key puts the screenshot into the so called clipboard. To get a file from it use the key combination windows + print screen. The screenshot will then be found in your picture folder under the subfolder screenshots. See

Instead of using windows+print screen you can also paste the clipboard content in for example paint (with crtl+v) and save from there.

You can even try if crtl+v works directly in the forum answer field (I seem to remember it working on github not sure if i ever tried it here on the forum).

Windows 10 has better snipping tool, invoked by win+shift+s by default. It will give you a graphical crosshair cursor and allow you to only capture specific region of the screen (drag-click a rectangle). After that it’s in the clipboard and you can directly paste it as picture in this forum reply field using ctrl-v.


I use a free and opensource application called Greenshot for my screen grabbing, it has some nice editing and markup features as well


My linux box also has a screenshot program hidden under the “print screen” button, and I use it quite often to post screenshots on this forum.

There are a lot of different scheen shot programs for Linux. The one I use comes default with Linux Mint. The first thing it does is ask me what sort of screenshot I want to make, and a bit of a pause.
The pause is quite handy. I can for example use it to select a window or open a menu I want to make a screenshot of.
Here I used it with a delay to make a screenshot of the screenshot program:


After the screenshot is made, I get another menu, with a few selections:

  • Save to disk.
  • Save to Clipboard.
  • Open in a drawing program.

To make a screenshot of the screenshot program, I selected “full screen” to have plenty of pixels and a few seconds delay to be able to pop up the screenshot editor.
After the actual screenshot was made, I opened it in the editor, and then made a 3rd screenshot from the screenshot made with the screenshot program in the editor.

This last screenshot I put in the clipboard, and posted here by just pressing [Ctrl + V] in this text window.
It works quite convenient. No messing around with file locations, or directories, or even thinking about a file name. Just a few key strokes and mouse clicks.

I tried it out and it works perfectly!!! Thank very much!!!

1 Like